summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-22 04:28:04 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-22 04:28:04 +0200
commit57659ee48186ab17a5d0feb360f20419fc10a0fc (patch)
tree42276e18fabef7d5122a3899a9d3684addde7b5d /dev-python
parentdev-python/thrift: Bump to 0.21.0 (diff)
downloadgentoo-57659ee48186ab17a5d0feb360f20419fc10a0fc.tar.gz
gentoo-57659ee48186ab17a5d0feb360f20419fc10a0fc.tar.bz2
gentoo-57659ee48186ab17a5d0feb360f20419fc10a0fc.zip
dev-python/configobj: Bump to 5.0.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/configobj/Manifest1
-rw-r--r--dev-python/configobj/configobj-5.0.9.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/configobj/Manifest b/dev-python/configobj/Manifest
index 737c0496a495..0c32f6bdd3f4 100644
--- a/dev-python/configobj/Manifest
+++ b/dev-python/configobj/Manifest
@@ -1 +1,2 @@
DIST configobj-5.0.8.gh.tar.gz 99071 BLAKE2B 61fb8622f3771f56f3a67511ce0eee11b9022a47a6a48858fafad966dd7fb18387d18dc0c32984bec064c2b03a7c72570248a967bf428f871c5b8ba4353a71e7 SHA512 26cdfec9f4d7adbab579191b29e6642f4f2a6fc73353f877565b76682d6087748f466f9cbb82fccfb2d409bace29c377c2276848179f5cb396e6ff1375c8edf2
+DIST configobj-5.0.9.gh.tar.gz 98246 BLAKE2B a91e2fd8aa19bae699e8edd5e5f60f0cfdebd28026a4582ac5a0afc11db9456e498ea1f2251e6d8223984f5a679a581cdf16fc9ba5e25ba490b4786d5cc092c2 SHA512 95ca81f785aacdd6c17b36b937e3338a8a72491ea153fc10db3eb038332d389c6cea0dca4cc8df803495e3d326e25e2e56a1741b84ea57c0159d38d3ded52fc0
diff --git a/dev-python/configobj/configobj-5.0.9.ebuild b/dev-python/configobj/configobj-5.0.9.ebuild
new file mode 100644
index 000000000000..5db01e998b19
--- /dev/null
+++ b/dev-python/configobj/configobj-5.0.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple config file reader and writer"
+HOMEPAGE="
+ https://github.com/DiffSK/configobj/
+ https://pypi.org/project/configobj/
+"
+SRC_URI="
+ https://github.com/DiffSK/configobj/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest