summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-13 07:09:05 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-13 07:28:33 +0200
commit5b3d93d74f4a9dced789a0a3588e93ed0113597c (patch)
tree554ddf9dee20eb0f199023caf89cd01b8a6bd585 /dev-python
parentdev-python/cfn-lint: Bump to 0.78.1 (diff)
downloadgentoo-5b3d93d74f4a9dced789a0a3588e93ed0113597c.tar.gz
gentoo-5b3d93d74f4a9dced789a0a3588e93ed0113597c.tar.bz2
gentoo-5b3d93d74f4a9dced789a0a3588e93ed0113597c.zip
dev-python/jsonschema: Bump to 4.18.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jsonschema/Manifest1
-rw-r--r--dev-python/jsonschema/jsonschema-4.18.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index 437d4e4e0a8e..110888e9cff7 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -1,2 +1,3 @@
DIST jsonschema-4.17.3.tar.gz 297785 BLAKE2B a0383bf5612ae50e94c95dbc1774d796b62c74a7aae3056a40edb7e042ad07fd7885e61d86220120a906a4017afe30d8ee8edbbf0cf01a6dec1f212984ff1c1e SHA512 626fc913c37d2e49e4b47c9e058aab4a96c1dc50c35d8def0b2ea0ca464dc25e3318d4fde4927c11ca38068743cd81779d5189464b821407ac1de1788bad30e2
DIST jsonschema-4.18.0.tar.gz 315551 BLAKE2B 0f885362b6c1af6385be88770b1f332f38e270ea48c81d2ab6ab37503b007bf2d7a3419c9d435e919fea7c6f6d4b3d1c84a5fd4f196237507c9803473a879f4d SHA512 83eee5a752f14475b32405a916790f033eaeb4cc4b69625abb4915972e5832878a0aa2c51c5c782169bfef5537f3072bd41682e2752380435f7de1162e66f4c1
+DIST jsonschema-4.18.2.tar.gz 314916 BLAKE2B 4e63e56ea34b0f315e0ee6e506157c294030e181aa6f06d523d70b24060618f9cf7cfaf6d3c6ef4fc93950dd42b628f62a488c3636cbe636e463b8a31b661a3a SHA512 38e2fb03836b8021c5f3a4db4e8d98922d565ae8bb2843cbb9b93b8be26f003b356c635d6b00d9881fcd438ed5a5304536fcad4acbc69d1de51c838cc3cd217a
diff --git a/dev-python/jsonschema/jsonschema-4.18.2.ebuild b/dev-python/jsonschema/jsonschema-4.18.2.ebuild
new file mode 100644
index 000000000000..daf147af3297
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-4.18.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema/
+ https://github.com/python-jsonschema/jsonschema/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-specifications-2023.03.6[${PYTHON_USEDEP}]
+ >=dev-python/referencing-0.28.4[${PYTHON_USEDEP}]
+ >=dev-python/rpds-py-0.7.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+"
+
+# formatter deps
+RDEPEND+="
+ dev-python/fqdn[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/isoduration[${PYTHON_USEDEP}]
+ >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3986-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/uri_template[${PYTHON_USEDEP}]
+ >=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires pip, does not make much sense for the users
+ jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
+ # fragile warning tests
+ jsonschema/tests/test_deprecations.py
+ # wtf?
+ jsonschema/tests/test_jsonschema_test_suite.py::test_suite_bug
+)