summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-21 05:51:26 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-21 05:51:26 +0200
commit617cc308f256a7d7f2b05a8f487935b2f3184d41 (patch)
treed3e9ba017363642980fa9a88505fcacb66f8ea95 /dev-python
parentdev-python/pyproject-fmt: Copy ~riscv forward (diff)
downloadgentoo-617cc308f256a7d7f2b05a8f487935b2f3184d41.tar.gz
gentoo-617cc308f256a7d7f2b05a8f487935b2f3184d41.tar.bz2
gentoo-617cc308f256a7d7f2b05a8f487935b2f3184d41.zip
dev-python/requests: Bump to 2.32.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/requests/Manifest1
-rw-r--r--dev-python/requests/requests-2.32.1.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/requests/Manifest b/dev-python/requests/Manifest
index 0ff86da8cb06..eeb595216333 100644
--- a/dev-python/requests/Manifest
+++ b/dev-python/requests/Manifest
@@ -1 +1,2 @@
DIST requests-2.31.0.tar.gz 110794 BLAKE2B e4e2781b272ccd94230c5b8c1bea83901bc8c28a34880709dbb95b887417b47833512e25045dab6e4226295294e2bf56fc821b6f636ae28aefdeee6039f53d44 SHA512 ce50d64973752f4cf7f7c7c91401669854b55c66d7465bea3689772fae8a6b646cf6720d84a2984bbe6fd78fc8b9ce0aa377f291fb6d7c20c7c2a4be8193acdd
+DIST requests-2.32.1.tar.gz 129920 BLAKE2B 9f46afeb3ea62e8bb537fb793bcf1b65b5cc2ae3f22263151b0bf5879aa2a11a1e87777453cc325f552964551750ef81524ef99ce132bb19df5161e1df5fe77f SHA512 6ae12ca26f04c3c001ef1882d17cd7f12412114214961db42d6b5f3f507640d1f07e325034761e02e7e5d9daacaab10a16884c2cb2c4128ca059a142b52bace8
diff --git a/dev-python/requests/requests-2.32.1.ebuild b/dev-python/requests/requests-2.32.1.ebuild
new file mode 100644
index 000000000000..35aa92871750
--- /dev/null
+++ b/dev-python/requests/requests-2.32.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="HTTP library for human beings"
+HOMEPAGE="
+ https://requests.readthedocs.io/
+ https://github.com/psf/requests/
+ https://pypi.org/project/requests/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+IUSE="socks5 test-rust"
+
+RDEPEND="
+ >=dev-python/certifi-2017.4.17[${PYTHON_USEDEP}]
+ <dev-python/charset-normalizer-4[${PYTHON_USEDEP}]
+ <dev-python/idna-4[${PYTHON_USEDEP}]
+ <dev-python/urllib3-3[${PYTHON_USEDEP}]
+ socks5? ( >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}] )
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-httpbin-2.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet (doctests)
+ requests/__init__.py::requests
+ requests/api.py::requests.api.request
+ requests/models.py::requests.models.PreparedRequest
+ requests/sessions.py::requests.sessions.Session
+ # require IPv4 interface in 10.* range
+ tests/test_requests.py::TestTimeout::test_connect_timeout
+ tests/test_requests.py::TestTimeout::test_total_timeout_connect
+ # TODO: openssl?
+ tests/test_requests.py::TestRequests::test_pyopenssl_redirect
+ # flask-2
+ tests/test_requests.py::TestRequests::test_cookie_sent_on_redirect
+ tests/test_requests.py::TestRequests::test_cookie_removed_on_expire
+ tests/test_requests.py::TestPreparingURLs::test_redirecting_to_bad_url
+ )
+
+ case ${EPYTHON} in
+ python3.13)
+ ;&
+ python3.12)
+ EPYTEST_DESELECT+=(
+ # different repr()
+ requests/utils.py::requests.utils.from_key_val_list
+ )
+ ;;
+ esac
+
+ if ! has_version "dev-python/trustme[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_requests.py::TestRequests::test_https_warnings
+ )
+ fi
+
+ epytest
+}