summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-02-13 20:11:58 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-02-13 20:12:32 +0100
commit82d182ae783eab0736f732c51312273d23f3af79 (patch)
treee1fe7f58353f8fde878935d2b7d6b1a3d1f7cf29 /dev-python
parentprofiles: mips 23.0 split-usr musl: reorganize for proper inheritance (diff)
downloadgentoo-82d182ae783eab0736f732c51312273d23f3af79.tar.gz
gentoo-82d182ae783eab0736f732c51312273d23f3af79.tar.bz2
gentoo-82d182ae783eab0736f732c51312273d23f3af79.zip
dev-python/notebook: add 7.1.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/notebook/Manifest1
-rw-r--r--dev-python/notebook/notebook-7.1.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/notebook/Manifest b/dev-python/notebook/Manifest
index 394169d19581..56d70c1f9f8a 100644
--- a/dev-python/notebook/Manifest
+++ b/dev-python/notebook/Manifest
@@ -1,2 +1,3 @@
DIST notebook-7.0.7.tar.gz 3936954 BLAKE2B 9171ae3974bd4eb36c804858224c386292a3772633017a8bf0c0ef408526278234b022087faad7930aa975c66762690e24a5a368bf9290937bdc8dff63757575 SHA512 05725f6bae2d916c9393f483a05696f6eb0e38a1b15a8427cbd61f508a06d78ead8a70c8764a00403c323b25a1278ea3a8daaf1ff5b5eeb0b35f6ed5e64ea638
DIST notebook-7.0.8.tar.gz 3937092 BLAKE2B eb0276f42018e6c577a67ebbfc3c1bc7d81a9b1fd0ba039d1e6a7f3973edb35f3000a6720cf6af136a90c6268e711507155a872e02f91eeb39633e2faa55ae93 SHA512 d5616efcdf5863b5bb0b5d3be92654835773b49aa47660f2cd593240f9695ff2797233545be6215a5d0098501e8fa39f4123bf4348e1113b3be5ea29d51662f5
+DIST notebook-7.1.0.tar.gz 4896581 BLAKE2B 441aaa42f7fac8840c81fefbf1f43f8789a39c4294a1cfa7aa772bf803bde8de2635a5fdc5e4688254d0c280bc7f17ad144009ae1857054852347c52b73f4cdd SHA512 d456dcc6c4b40c646bb7eb77e6a59cd5a947148b05e3930e992a00d2a285c8867e42bf04a3c0cb45d2b5491f9da10a8e12727dc0de84728a6cdf91184c083aca
diff --git a/dev-python/notebook/notebook-7.1.0.ebuild b/dev-python/notebook/notebook-7.1.0.ebuild
new file mode 100644
index 000000000000..31ad57353c3d
--- /dev/null
+++ b/dev-python/notebook/notebook-7.1.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi xdg-utils
+
+DESCRIPTION="Jupyter Interactive Notebook"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/notebook/
+ https://pypi.org/project/notebook/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter-server-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-4.1.1[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-4.2[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-server-2.22.1[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-server-3[${PYTHON_USEDEP}]
+ >=dev-python/notebook-shim-0.2[${PYTHON_USEDEP}]
+ <dev-python/notebook-shim-0.3[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/hatch-jupyter-builder[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/nbval[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-unixsocket[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}