summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-01 07:05:43 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-01 08:09:10 +0100
commit90fe18d90389de0a7430828ad0dbf0016494781d (patch)
treead97a9bdfa7c263c0d0b389c021f3a43bfe9a6e4 /dev-python
parentdev-python/google-api-python-client: Bump to 2.68.0 (diff)
downloadgentoo-90fe18d90389de0a7430828ad0dbf0016494781d.tar.gz
gentoo-90fe18d90389de0a7430828ad0dbf0016494781d.tar.bz2
gentoo-90fe18d90389de0a7430828ad0dbf0016494781d.zip
dev-python/ansible-compat: Bump to 2.2.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ansible-compat/Manifest1
-rw-r--r--dev-python/ansible-compat/ansible-compat-2.2.6.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index 7fe1778c8f3d..031010392171 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -2,3 +2,4 @@ DIST ansible-compat-2.2.1.tar.gz 39126 BLAKE2B c4d0512606c99ba8f07e0287620c94af6
DIST ansible-compat-2.2.3.tar.gz 39603 BLAKE2B 16b88a1c669a74d858e4d47539811b33db77561f7e72088d5eece67ee1594e65a9328277bc65b96dce726180c29118b2b240b45541b6548b34584d643f836894 SHA512 4944ff97524734c445438c052aeedd0d526b58e91a56e0bcc32123fb3a9464c82f7718ea1897a09ef0dd33dfa36abdc6e0a0157e9a4eb8d341cbd712b2f538d1
DIST ansible-compat-2.2.4.tar.gz 39772 BLAKE2B a4874675086956e11de4df4068e3b17b65b4f9f7610bb88bfba308d880fe478e39a4450a362bb06a555a36a41731f336c51756893ebe65715fc022421c51a293 SHA512 ec30329b2aa07ea7685a8cd91438f0d0e9003644fb3d15a842277abc7f5f1eeed61bb606ca594d6496e1980be0109dd5e4021bc4aeb66d909a312bf02649a1b9
DIST ansible-compat-2.2.5.tar.gz 39794 BLAKE2B 25a5c858eb3e120b7f51b8800b01eff2482a03d0e5f5c049d4ff2bc96ab2c01e856284f3328d5c9e3621b2d769df4450c9427997b48a7ddd337b01aa777e0c28 SHA512 8029d6dbd093414fb5eccba1789c881601a3a1f45bf7779f9e2af886d457e9c57a4e6432eed73a1d387b4d82617e1677a857cf0d2dfdcebcefa0dc790b2ec2d4
+DIST ansible-compat-2.2.6.tar.gz 38890 BLAKE2B 5022676dca1c2cb24e8f3e3387de8ef214979124b6d4a819f6328b2ffa0b19bddc5ef60131eb0133d809a214ecdf39fb5c01b197a44111e05a23740d4955c00c SHA512 b02faeb0202839c01a777277cd077264b44fbadbef679e93cb4ac0be3b81df921bc8f000e27372446326976acd1b42f1f1f42896ff0af9ba0677e7a93d06b195
diff --git a/dev-python/ansible-compat/ansible-compat-2.2.6.ebuild b/dev-python/ansible-compat/ansible-compat-2.2.6.ebuild
new file mode 100644
index 000000000000..ea13f54d55c0
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-2.2.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.3.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-7.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+)
+
+distutils_enable_sphinx docs \
+ dev-python/ansible-pygments \
+ dev-python/myst_parser \
+ dev-python/sphinx_ansible_theme
+distutils_enable_tests pytest