summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-11 20:11:48 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-11 20:39:30 +0200
commita63ebcbc61ebb6a12e348c43e4372b554c351132 (patch)
tree74b951118d0643da74ecbfae3bdbc8aef7558057 /dev-python
parentmedia-gfx/fotema: Remove old (diff)
downloadgentoo-a63ebcbc61ebb6a12e348c43e4372b554c351132.tar.gz
gentoo-a63ebcbc61ebb6a12e348c43e4372b554c351132.tar.bz2
gentoo-a63ebcbc61ebb6a12e348c43e4372b554c351132.zip
dev-python/simsimd: Bump to 5.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/simsimd/Manifest1
-rw-r--r--dev-python/simsimd/simsimd-5.1.3.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/simsimd/Manifest b/dev-python/simsimd/Manifest
index 2507102801c4..fbdeaea386de 100644
--- a/dev-python/simsimd/Manifest
+++ b/dev-python/simsimd/Manifest
@@ -1 +1,2 @@
DIST SimSIMD-5.0.1.gh.tar.gz 120754 BLAKE2B 35094cf15aad8f2325706a604eb7036e3edc18828c2341d9921b76077d7d7de9028177277ea32a144fa7edd98ee2b83d83506e632f95889c2290102c9638df9e SHA512 0dde560764e4d267e7b3387e8c7e24a44da02362f651b9ea48d44f91908135d107080c8b7db2fb3578f5ebfa67082694eb2907d82ceef841271f0debf42f1a8a
+DIST SimSIMD-5.1.3.gh.tar.gz 149123 BLAKE2B 1ac5d4245486a45ab73efe58733c22b9928beca09117d9c7a30ff920f595d7d5a315caa4e71ca951651462c77b794c7157add4783bede40c63d8ca1783365912 SHA512 707ce791c4e5cf866a690f6003ae64a052dfecb26c103d84dbe6fb43e35364b1d1fcf7a49dd1445063e471d06c760a432847c45476767b26b7ca11bcc4c555b0
diff --git a/dev-python/simsimd/simsimd-5.1.3.ebuild b/dev-python/simsimd/simsimd-5.1.3.ebuild
new file mode 100644
index 000000000000..944fe4d547ec
--- /dev/null
+++ b/dev-python/simsimd/simsimd-5.1.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 toolchain-funcs
+
+MY_P=SimSIMD-${PV}
+DESCRIPTION="Fastest SIMD-Accelerated Vector Similarity Functions for x86 and Arm"
+HOMEPAGE="
+ https://github.com/ashvardanian/SimSIMD/
+ https://pypi.org/project/simsimd/
+"
+# no sdist, as of 4.3.1
+# https://github.com/ashvardanian/SimSIMD/issues/113
+SRC_URI="
+ https://github.com/ashvardanian/SimSIMD/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="openmp"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-repeat[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ fi
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ fi
+}
+
+src_prepare() {
+ sed -i -e '/-O3/d' setup.py || die
+ if ! use openmp; then
+ sed -i -e '/-fopenmp/d' setup.py || die
+ fi
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p repeat python/test.py
+}