summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-24 08:31:04 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-24 12:17:15 +0100
commitc0c62ea0cdbfcffb3f87779563e0e951ff7ba571 (patch)
tree9fd2c072b858c7d2887ac6f0dbb7585c658de5d8 /dev-python
parentdev-python/flatbuffers: Bump to 24.12.23 (diff)
downloadgentoo-c0c62ea0cdbfcffb3f87779563e0e951ff7ba571.tar.gz
gentoo-c0c62ea0cdbfcffb3f87779563e0e951ff7ba571.tar.bz2
gentoo-c0c62ea0cdbfcffb3f87779563e0e951ff7ba571.zip
dev-python/cerberus: Bump to 1.3.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cerberus/Manifest1
-rw-r--r--dev-python/cerberus/cerberus-1.3.6.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/cerberus/Manifest b/dev-python/cerberus/Manifest
index 9b2665fefda9..a27a86a6ef20 100644
--- a/dev-python/cerberus/Manifest
+++ b/dev-python/cerberus/Manifest
@@ -1 +1,2 @@
DIST cerberus-1.3.5.gh.tar.gz 921848 BLAKE2B 1f7f1c6804702dea6ab31c3e278a4d769c80c898e786aa7c7f7df0bc212edf07c4026c5dd6adf7ecdcacfd596ec33c3493ec26c3de68bd8254fce56e6532fff7 SHA512 eaa91f229a009770a1750a51e82c34f06dffeebca7af7cafd5ba3a8529502326dd20af1ed7a60fd5e5ed28edb4b974712b1493aa1e330097a8e36ad70c5e4f23
+DIST cerberus-1.3.6.gh.tar.gz 920930 BLAKE2B 168ca5e628448a4477f1aec7f1371cdf8c89c0e40c3e3f10bd3b6da1c7d78580e0db4403c8f2abe98baa7db5cbbe1b92241af725bacd9f3eced899397bafe8eb SHA512 2ee32ade240198af6aa2927d80a24e00a5d4aac22486aa13b375f7235e5491a2c61910a16e1d965c0e57cf226a3865675f2037e281d1461b262c6cbb13cb6271
diff --git a/dev-python/cerberus/cerberus-1.3.6.ebuild b/dev-python/cerberus/cerberus-1.3.6.ebuild
new file mode 100644
index 000000000000..3d821d540124
--- /dev/null
+++ b/dev-python/cerberus/cerberus-1.3.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight and extensible data-validation library for Python"
+HOMEPAGE="
+ https://docs.python-cerberus.org/
+ https://github.com/pyeve/cerberus/
+ https://pypi.org/project/Cerberus/
+"
+SRC_URI="
+ https://github.com/pyeve/cerberus/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+EPYTEST_DESELECT=(
+ # Require currently unpackaged pytest-benchmark, more useful
+ # to developers than to end users.
+ cerberus/benchmarks/
+)
+
+distutils_enable_tests pytest