summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-02-23 10:22:10 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-26 15:45:35 +0100
commitd78c5d289ec3db8335f48433414bef1f696d06dc (patch)
tree4b7e50d5cc64de4687203b02a022231cf0dbb3fc /dev-python
parentdev-tex/rubber: mark Python 3.11 compatible (diff)
downloadgentoo-d78c5d289ec3db8335f48433414bef1f696d06dc.tar.gz
gentoo-d78c5d289ec3db8335f48433414bef1f696d06dc.tar.bz2
gentoo-d78c5d289ec3db8335f48433414bef1f696d06dc.zip
dev-python/configshell-fb: enable py3.11
- update EAPI 7 -> 8 - enable py3.11 - migrate to PEP517 - use github source instead of pypi - apply two patches from upstream fixing deprecated function in py3.11 - add simple smoke test from examples, the proper test suite is missing Closes: https://bugs.gentoo.org/896764 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/configshell-fb/Manifest3
-rw-r--r--dev-python/configshell-fb/configshell-fb-1.1.29-r1.ebuild44
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/configshell-fb/Manifest b/dev-python/configshell-fb/Manifest
index 13fc21a18c1e..be1b38506a9b 100644
--- a/dev-python/configshell-fb/Manifest
+++ b/dev-python/configshell-fb/Manifest
@@ -1 +1,4 @@
+DIST configshell-fb-1.1.29-replace-getargspec-1.patch 1398 BLAKE2B 650efe1dad551ad040001cb2f576311806d329bd430874e1dac38a5cb94c4801140f32b628e0089809214466613e8f207ba3aff1a87dd8ca29c05593b551e5d7 SHA512 59c320939d4590dc2933de7d0ad613efd7236868fd898ce1edadbc55d1ecd8667e28a5c03caa80ea12420db3dd0e4de8c36ef5528352920d98acfd881648154a
+DIST configshell-fb-1.1.29-replace-getargspec-2.patch 2981 BLAKE2B 88400de96d329c0efd2a9e9cb41f1c53e62c28507439c405874726fccc6093d5fe37e52b6e4b811bf0ccc7616c9a26b83b17e39a257aeab3c4114e1486a32575 SHA512 621b125cde9fcc68f46a3a32fd78190a46f900ec808233a60c4beb22c6109165f0743a341991e6c556dc5a76b7c6a42b703f2a6be91915110f196845a3fa111c
+DIST configshell-fb-1.1.29.gh.tar.gz 33192 BLAKE2B 6c9c2146a597572675611afe259122b0ec9614295c4b9b4056d7a16f35004700b1e6fc29e1bf868d9ba6291b781ca35eab77e8adf23c6d23e09de2fb94626f26 SHA512 1b5f573506317119d2420e415abbb856692caa65a7f407f741300eec302d1b442e29d2691f6a192b202b2a5731a7a179d1b03f6cd27780876194d97e4df5f7d0
DIST configshell-fb-1.1.29.tar.gz 55036 BLAKE2B 4a9a8f2573b43a9c8ddbda837e831c96b221f4499acb1aeeb990a7b1050c5572e9b745857ac9d1de4089d1758dd1284d0555da524def80e0a1caac18bb43a921 SHA512 0d7663cf58431c8b0be5618e5ef454838489e11a3074e5bd63145c3ea965065e37f1a41b5775363a35498a4d5dd86ad5453feb58dd74853cd77ae196b44c658e
diff --git a/dev-python/configshell-fb/configshell-fb-1.1.29-r1.ebuild b/dev-python/configshell-fb/configshell-fb-1.1.29-r1.ebuild
new file mode 100644
index 000000000000..633970b1409b
--- /dev/null
+++ b/dev-python/configshell-fb/configshell-fb-1.1.29-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A Python library for building configuration shells"
+HOMEPAGE="
+ https://github.com/open-iscsi/configshell-fb/
+ https://pypi.org/project/configshell-fb/
+"
+SRC_URI="
+ https://github.com/open-iscsi/configshell-fb/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://github.com/open-iscsi/configshell-fb/commit/f3ac914861bd605e3d634aeeb5e706abdbd39259.patch
+ -> ${P}-replace-getargspec-1.patch
+ https://github.com/open-iscsi/configshell-fb/commit/50d5ffe9f213a53588cec88c9919c816b3fa7736.patch
+ -> ${P}-replace-getargspec-2.patch
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ # Python3.11 fixes of deprecated getargspec function taken from upstream:
+ # - https://github.com/open-iscsi/configshell-fb/pull/64
+ "${DISTDIR}/${P}-replace-getargspec-1.patch"
+ # - https://github.com/open-iscsi/configshell-fb/pull/65
+ "${DISTDIR}/${P}-replace-getargspec-2.patch"
+)
+
+python_test() {
+ "${EPYTHON}" examples/myshell || die "Test failed with ${EPYTHON}"
+}