summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-12 09:20:32 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-12 10:09:47 +0100
commitec4fd4e13bf862252769b823aa843617719ce9f8 (patch)
treefd225bd607de69e356018bd035db8373e9ea0d32 /dev-python
parentdev-python/cffi: Bump to 1.14.5 (diff)
downloadgentoo-ec4fd4e13bf862252769b823aa843617719ce9f8.tar.gz
gentoo-ec4fd4e13bf862252769b823aa843617719ce9f8.tar.bz2
gentoo-ec4fd4e13bf862252769b823aa843617719ce9f8.zip
dev-python/botocore: Bump to 1.20.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.6.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 85889e103873..70da480a3ec5 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -11,3 +11,4 @@ DIST botocore-1.20.2.tar.gz 7446650 BLAKE2B 777dbcbfcd824a7d009ffc3a1aec8afbd14a
DIST botocore-1.20.3.tar.gz 7446281 BLAKE2B 536cbe8f6b6c150f3c66468f3e0c51ae0e602f277ff64ee67a2f149c0481fe603b10439e2fa37831b106d7ca4b23d1e7037cfc55c8e7caf06b8f9cf5561d9544 SHA512 ad0982fb9095e4d8e36a5805f5041fa1241526409d6a1fad3628c52d9870e54fd4a828816eb77f39b60f49ade7805e97cd286f7ac4070ebafbb696e513691e0f
DIST botocore-1.20.4.tar.gz 7447611 BLAKE2B 05cb501cf40748ac1053c4687bd6de7a17d9ac31fe688de8d6aaf8047260f230ea14cc947c4c208a11d26477508b38428fdca116b9fa8212c5ee6ac020a6367f SHA512 b3ec1597b1cf4e9d18e21216f9ba703e4ae0a924653d21cfd93eeffbb13041ad96c3cd099ff1c8631bdcd5c7d6a70e6d36848fdbc44de9f7cebf7ee223918743
DIST botocore-1.20.5.tar.gz 7447859 BLAKE2B 56b6ecbec1834c414983679e4f3cd01f295c48c87bc972ccec77fe972b88a1785ef82c403576f6aa96ebe9041a29535566280228f8b5a5e35d2e4fdb14cac472 SHA512 488584be3ea9b8a7467384a3947349704d0bf0e6817936a70fda69bc8d682d88601188446d50eeae29b4f0680e8f20d717519011d6beecd3f35cb322fb526853
+DIST botocore-1.20.6.tar.gz 7450975 BLAKE2B 56ad69b958233a94f6bacff28bffb644bde8cc87dcb8d842f542059548d2aaf5762666077f9b429bc0487808282b806725a05dcd3def6c975f4418f209fc2ec8 SHA512 558c3c3b123aeeeb5aff420e7ff3edbba9165e1cf434f8136ead21e9d94dd85d857732902b10e09386ddc80754d7be37970573ce039296e532b593a101a97950
diff --git a/dev-python/botocore/botocore-1.20.6.ebuild b/dev-python/botocore/botocore-1.20.6.ebuild
new file mode 100644
index 000000000000..4e5d698e619b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}