summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2016-06-14 20:28:01 +0200
committerDavide Pesavento <pesa@gentoo.org>2016-06-14 20:28:46 +0200
commit83c74e8e63a586c11302e92bcc9b6b5bcda8346c (patch)
tree35c37915f468728642e6590be16d1904ce2f6da1 /dev-qt/qtlocation
parentnet-p2p/syncthing: remove old (diff)
downloadgentoo-83c74e8e63a586c11302e92bcc9b6b5bcda8346c.tar.gz
gentoo-83c74e8e63a586c11302e92bcc9b6b5bcda8346c.tar.bz2
gentoo-83c74e8e63a586c11302e92bcc9b6b5bcda8346c.zip
dev-qt: Qt 5.6.1 version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-qt/qtlocation')
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-5.6.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index c55333aa514d..015f38ca269f 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1 +1,2 @@
DIST qtlocation-opensource-src-5.6.0.tar.xz 3076136 SHA256 360e1519d0fcafe4f86923d224e76d56dd785dfb0e1a19fd2e2b0016799653c9 SHA512 76cc7f27a043999af56f7bec408c46f0bb0709f651a3d84084f7ae92c3f50f6450420bdda31db17436111df537b94d51a9ca2819cce13ce83c538490d3f62a1d WHIRLPOOL b4bd14bb1882155ae9143d66ae99191dd95b89860ca609bbf5cffedec745f026369ce12df0bfd40c9b79d74f26036c184ebadee11dcd929a1f6a4d01634a2ab2
+DIST qtlocation-opensource-src-5.6.1.tar.xz 3046500 SHA256 d3b5768cf68945cd00c9df32fb87ca3bf85f5364dc2e441780840e2bd4d15061 SHA512 c4983ea9998aa96778ea552e7ac698188d4201685b75527fc97b51b112b0e3950171f34e14907862e43b58677a7d071c7542dd96c7c7a3d6f48b9270b2d6bc92 WHIRLPOOL 4a8b8fe2e64ec189e3e1a670b5b2491b3b6556f276b8ec31d2455f5615192ccfb2a879eda53fc148906e0d91160f0e6508c7e25d5236d6f395e48ea24e210210
diff --git a/dev-qt/qtlocation/qtlocation-5.6.1.ebuild b/dev-qt/qtlocation/qtlocation-5.6.1.ebuild
new file mode 100644
index 000000000000..b0d8a7717791
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="The Location module for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtpositioning-${PV}
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty
+ src/location
+ src/imports/location
+ src/plugins/geoservices
+)