summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-03 06:11:11 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-05 09:01:12 -0400
commitae425888b5df9a985c56f7aae6c6253b240f9561 (patch)
tree8aee86eeac06bbea2b9151744046fa0d8920f325 /dev-qt/qtquicktimeline
parentdev-qt/qtnetworkauth: remove unnecessary qtbase[widgets] (diff)
downloadgentoo-ae425888b5df9a985c56f7aae6c6253b240f9561.tar.gz
gentoo-ae425888b5df9a985c56f7aae6c6253b240f9561.tar.bz2
gentoo-ae425888b5df9a985c56f7aae6c6253b240f9561.zip
dev-qt/*: replace = by ~ for dev-qt/*:6 deps
Less jarring a little bit shorter. Made sense in Qt5 given it used a ver_cut QT5_PV and could be used to ignore additional components, but with PV it does nothing useful. Plus we still want _rc and _betas to match (_p<date> are where issues start though, if ever needed we could reintroduce QT6_PV, but for now...). Should have done this in the previous style commit. Still keeping :6, do prefer these being everywhere for clarity with Qt slots (and qa-vdb!) even if essentially a no-op here. Plus, even if this does not happen with Qt, two slots having the same version can happen with revisions (e.g. current webkit-gtk). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtquicktimeline')
-rw-r--r--dev-qt/qtquicktimeline/qtquicktimeline-6.5.2.ebuild4
-rw-r--r--dev-qt/qtquicktimeline/qtquicktimeline-6.5.9999.ebuild4
-rw-r--r--dev-qt/qtquicktimeline/qtquicktimeline-6.9999.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/dev-qt/qtquicktimeline/qtquicktimeline-6.5.2.ebuild b/dev-qt/qtquicktimeline/qtquicktimeline-6.5.2.ebuild
index 76d4c78cfff9..48f8a5bde6c4 100644
--- a/dev-qt/qtquicktimeline/qtquicktimeline-6.5.2.ebuild
+++ b/dev-qt/qtquicktimeline/qtquicktimeline-6.5.2.ebuild
@@ -12,7 +12,7 @@ if [[ ${QT6_BUILD_TYPE} == release ]]; then
fi
RDEPEND="
- =dev-qt/qtbase-${PV}*:6
- =dev-qt/qtdeclarative-${PV}*:6
+ ~dev-qt/qtbase-${PV}:6
+ ~dev-qt/qtdeclarative-${PV}:6
"
DEPEND="${RDEPEND}"
diff --git a/dev-qt/qtquicktimeline/qtquicktimeline-6.5.9999.ebuild b/dev-qt/qtquicktimeline/qtquicktimeline-6.5.9999.ebuild
index 76d4c78cfff9..48f8a5bde6c4 100644
--- a/dev-qt/qtquicktimeline/qtquicktimeline-6.5.9999.ebuild
+++ b/dev-qt/qtquicktimeline/qtquicktimeline-6.5.9999.ebuild
@@ -12,7 +12,7 @@ if [[ ${QT6_BUILD_TYPE} == release ]]; then
fi
RDEPEND="
- =dev-qt/qtbase-${PV}*:6
- =dev-qt/qtdeclarative-${PV}*:6
+ ~dev-qt/qtbase-${PV}:6
+ ~dev-qt/qtdeclarative-${PV}:6
"
DEPEND="${RDEPEND}"
diff --git a/dev-qt/qtquicktimeline/qtquicktimeline-6.9999.ebuild b/dev-qt/qtquicktimeline/qtquicktimeline-6.9999.ebuild
index 76d4c78cfff9..48f8a5bde6c4 100644
--- a/dev-qt/qtquicktimeline/qtquicktimeline-6.9999.ebuild
+++ b/dev-qt/qtquicktimeline/qtquicktimeline-6.9999.ebuild
@@ -12,7 +12,7 @@ if [[ ${QT6_BUILD_TYPE} == release ]]; then
fi
RDEPEND="
- =dev-qt/qtbase-${PV}*:6
- =dev-qt/qtdeclarative-${PV}*:6
+ ~dev-qt/qtbase-${PV}:6
+ ~dev-qt/qtdeclarative-${PV}:6
"
DEPEND="${RDEPEND}"