summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-05-26 02:05:18 +0300
committerSam James <sam@gentoo.org>2022-08-02 22:49:52 +0100
commit10466feba07a680c1cc0c47eddd257f10f34dbbd (patch)
treea78445e8f1b6a9a4a64a77f05fe730aaa5225c3c /dev-qt
parentdev-qt/qtquick3d: new package (diff)
downloadgentoo-10466feba07a680c1cc0c47eddd257f10f34dbbd.tar.gz
gentoo-10466feba07a680c1cc0c47eddd257f10f34dbbd.tar.bz2
gentoo-10466feba07a680c1cc0c47eddd257f10f34dbbd.zip
dev-qt/qt5compat: new package
Version 6.3.1 of the Qt module containing the unsupported Qt 5 APIs. Bug: https://bugs.gentoo.org/838970 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/25635 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qt5compat/Manifest1
-rw-r--r--dev-qt/qt5compat/metadata.xml17
-rw-r--r--dev-qt/qt5compat/qt5compat-6.3.1.ebuild18
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-qt/qt5compat/Manifest b/dev-qt/qt5compat/Manifest
new file mode 100644
index 000000000000..a656414f2973
--- /dev/null
+++ b/dev-qt/qt5compat/Manifest
@@ -0,0 +1 @@
+DIST qt5compat-everywhere-src-6.3.1.tar.xz 8195804 BLAKE2B 782da113f35ecd231ed408337fef8e6c688c5a1dc1b2533490d7bc751fa9d2404d45e16a47017d8ae6d7b8e7f077b33e94e82cfcd35bd4c81690422a36e29e73 SHA512 66196a8d29a2789179904638fcd9ec162d5715e7dc28618b3ef78d07682a05578b6c2e7023144c628b94321a9c1332d39826c13adb1e5db5121406c530c9c35c
diff --git a/dev-qt/qt5compat/metadata.xml b/dev-qt/qt5compat/metadata.xml
new file mode 100644
index 000000000000..32568f62fb8e
--- /dev/null
+++ b/dev-qt/qt5compat/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://bugreports.qt.io/</bugs-to>
+ <doc>https://doc.qt.io/</doc>
+ </upstream>
+ <slots>
+ <subslots>
+ Must only be used by packages that are known to use private parts of the Qt API.
+ </subslots>
+ </slots>
+</pkgmetadata>
diff --git a/dev-qt/qt5compat/qt5compat-6.3.1.ebuild b/dev-qt/qt5compat/qt5compat-6.3.1.ebuild
new file mode 100644
index 000000000000..2bf0684e946d
--- /dev/null
+++ b/dev-qt/qt5compat/qt5compat-6.3.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Qt module containing the unsupported Qt 5 APIs"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="
+ =dev-qt/qtbase-${PV}*[gui,network]
+ =dev-qt/qtdeclarative-${PV}*
+"
+RDEPEND="${DEPEND}"