summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-02-15 08:10:32 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-02-15 11:23:00 +0100
commit88035c952386afc72fbd21918deb8df32e1a13e7 (patch)
treede41751e0e63d1e460e7ce7881b828be77500c98 /dev-qt
parentdev-vcs/git-sizer: add myself as maintainer (diff)
downloadgentoo-88035c952386afc72fbd21918deb8df32e1a13e7.tar.gz
gentoo-88035c952386afc72fbd21918deb8df32e1a13e7.tar.bz2
gentoo-88035c952386afc72fbd21918deb8df32e1a13e7.zip
dev-qt/qtwayland: Bump 5.15.2-r20 in place to KDE d6a6b727
One patch was upstreamed. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwayland/Manifest2
-rw-r--r--dev-qt/qtwayland/files/qtwayland-5.15.2-simplify-roundtrip-behavior.patch82
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.2-r20.ebuild3
3 files changed, 2 insertions, 85 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index b81ab4d5cfd4..c5f631739822 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,2 +1,2 @@
DIST qtwayland-5.15.2-867540b9.tar.gz 830061 BLAKE2B b831288d6a3e671631b4df00eb1edb72e35128f3ed5a73983b3e15193f554fddcd0337deb832d44b795d2e37f0601fe35b8b0fcb5986bcc44154d172f3a54193 SHA512 b834802811d9f65559ef5e7468189b53c666e390aa09edeb490e5fee2dece13082b11da0f8b5924b89f7dc8e1eba375a485940f4dfbf0445f3d1e96033e33f24
-DIST qtwayland-5.15.2-9f66cd37.tar.gz 831912 BLAKE2B 6dd0d695ef70e453df6400b5eb9f21c585d65fcb9ede94c7f23bd6d2a65afcdaf51d400a703e507f70150213280be24aa3f4ea175c00a9ebf7a78a6752b5f1c9 SHA512 586fe1f87736ba7de67631575778cc3c1f36a76e2b97681bbb4465078a2b39e9bae5c11a552f662385298869ba31d203ef05b9a0bb40e77e242d829d3d82041b
+DIST qtwayland-5.15.2-d6a6b727.tar.gz 831439 BLAKE2B 430f7c8570f9941e80db68f63efa9669f40d045e8df8820ec8653152938078b91d8d68b76667c6c01cc83cfca3f3b0ea67b6fdee6230e04fd091dcaaed4400bc SHA512 a2314f31c979594c4bd46fe8f1ac44d3391e45e6fedef44eaac5fb8700d1b32ac992f3e9d17e2453f0311038979a2bf8fabb14ea887525e16fb210307844c71d
diff --git a/dev-qt/qtwayland/files/qtwayland-5.15.2-simplify-roundtrip-behavior.patch b/dev-qt/qtwayland/files/qtwayland-5.15.2-simplify-roundtrip-behavior.patch
deleted file mode 100644
index 2b210e849210..000000000000
--- a/dev-qt/qtwayland/files/qtwayland-5.15.2-simplify-roundtrip-behavior.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-From d6a6b727832819d118199f7016c2c401663ee370 Mon Sep 17 00:00:00 2001
-From: David Edmundson <davidedmundson@kde.org>
-Date: Wed, 9 Feb 2022 17:20:48 +0000
-Subject: [PATCH] client: Simplify round trip behavior
-
-The custom event queue was removed in
-302d4ffb8549214eb4028dc3e47ec4ee4e12ffbd (2015) so the comment about not
-being able to use the inbuilt round trip method no longer applies.
-
-This fixes a real world problem. Use of a blocking round trip should not
-process non wayland events. Doing so can lead to misbehaviour client
-side as things happen out of order. The move to the event thread created
-several regressions as we now get events before the QGuiApplication is
-fully constructed.
-
-Change-Id: I650481f49a47ed1a9778c7e1bc3c48db6e8f0031
-Reviewed-by: Vlad Zahorodnii <vlad.zahorodnii@kde.org>
-Reviewed-by: Eskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@qt.io>
-(cherry picked from commit 62646d9122845d7bd9104b610478cebde3e769c7)
----
- src/client/qwaylanddisplay.cpp | 43 +---------------------------------
- 1 file changed, 1 insertion(+), 42 deletions(-)
-
-diff --git a/src/client/qwaylanddisplay.cpp b/src/client/qwaylanddisplay.cpp
-index 6f1bada5..86045a35 100644
---- a/src/client/qwaylanddisplay.cpp
-+++ b/src/client/qwaylanddisplay.cpp
-@@ -611,50 +611,9 @@ uint32_t QWaylandDisplay::currentTimeMillisec()
- return 0;
- }
-
--static void
--sync_callback(void *data, struct wl_callback *callback, uint32_t serial)
--{
-- Q_UNUSED(serial)
-- bool *done = static_cast<bool *>(data);
--
-- *done = true;
--
-- // If the wl_callback done event is received after the condition check in the while loop in
-- // forceRoundTrip(), but before the call to processEvents, the call to processEvents may block
-- // forever if no more events are posted (eventhough the callback is handled in response to the
-- // aboutToBlock signal). Hence, we wake up the event dispatcher so forceRoundTrip may return.
-- // (QTBUG-64696)
-- if (auto *dispatcher = QThread::currentThread()->eventDispatcher())
-- dispatcher->wakeUp();
--
-- wl_callback_destroy(callback);
--}
--
--static const struct wl_callback_listener sync_listener = {
-- sync_callback
--};
--
- void QWaylandDisplay::forceRoundTrip()
- {
-- // wl_display_roundtrip() works on the main queue only,
-- // but we use a separate one, so basically reimplement it here
-- int ret = 0;
-- bool done = false;
-- wl_callback *callback = wl_display_sync(mDisplay);
-- wl_callback_add_listener(callback, &sync_listener, &done);
-- flushRequests();
-- if (QThread::currentThread()->eventDispatcher()) {
-- while (!done && ret >= 0) {
-- QThread::currentThread()->eventDispatcher()->processEvents(QEventLoop::WaitForMoreEvents);
-- ret = wl_display_dispatch_pending(mDisplay);
-- }
-- } else {
-- while (!done && ret >= 0)
-- ret = wl_display_dispatch(mDisplay);
-- }
--
-- if (ret == -1 && !done)
-- wl_callback_destroy(callback);
-+ wl_display_roundtrip(mDisplay);
- }
-
- bool QWaylandDisplay::supportsWindowDecoration() const
---
-GitLab
-
diff --git a/dev-qt/qtwayland/qtwayland-5.15.2-r20.ebuild b/dev-qt/qtwayland/qtwayland-5.15.2-r20.ebuild
index a4798f13a60b..715878b3b4d9 100644
--- a/dev-qt/qtwayland/qtwayland-5.15.2-r20.ebuild
+++ b/dev-qt/qtwayland/qtwayland-5.15.2-r20.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-KDE_ORG_COMMIT=9f66cd3784421ee5dc6538630ade0cf215f656aa
+KDE_ORG_COMMIT=d6a6b727832819d118199f7016c2c401663ee370
inherit qt5-build
DESCRIPTION="Wayland platform plugin for Qt"
@@ -36,7 +36,6 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${P}-QTBUG-90037-QTBUG-91264.patch"
"${FILESDIR}/${P}-fix-qmake-deps.patch"
- "${FILESDIR}/${P}-simplify-roundtrip-behavior.patch"
"${FILESDIR}/${P}-guard-mResizeDirty.patch"
"${FILESDIR}/${P}-fixup-mutexes.patch"
)