summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-01-01 20:59:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-01-01 22:01:23 +0100
commitb4391f4d6bcc82074f3dc48090c1b1e661d547ad (patch)
tree1a416ee0c0ee0b6439443d379a4c244e81d6d54e /dev-qt
parentdev-qt/qtplugininfo: add 5.15.12 (diff)
downloadgentoo-b4391f4d6bcc82074f3dc48090c1b1e661d547ad.tar.gz
gentoo-b4391f4d6bcc82074f3dc48090c1b1e661d547ad.tar.bz2
gentoo-b4391f4d6bcc82074f3dc48090c1b1e661d547ad.zip
dev-qt/qtpositioning: add 5.15.12
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtpositioning/Manifest1
-rw-r--r--dev-qt/qtpositioning/qtpositioning-5.15.12.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-qt/qtpositioning/Manifest b/dev-qt/qtpositioning/Manifest
index aeac827e28b0..d9fb204a1666 100644
--- a/dev-qt/qtpositioning/Manifest
+++ b/dev-qt/qtpositioning/Manifest
@@ -1,2 +1,3 @@
DIST qtlocation-everywhere-opensource-src-5.15.11.tar.xz 6554216 BLAKE2B e882ecdc4f565f48874371e5235dc96769fbded9446a2a7f1afd869217f4bc75a9f42c6c34627311b55fbfc60da9a95fc7472c3ced83fca722799497b437a9d9 SHA512 d439d03ff9044fc70165d1ceb5def9ec3290beec56b3e893409a24cd355651a4317e0eadff0266d38203ff84429a5fb8659a200f094669716579b6791a1a0f6d
+DIST qtlocation-everywhere-opensource-src-5.15.12.tar.xz 6553488 BLAKE2B e9cab8e6f62cc1cfc6586fa4a1b252bce915479fca5f9fbeac66a2494d77047af4af1ba840786799637edae3af7c6d2000f640af018548cfcd7bd624c6a31b15 SHA512 c480762cea2cd1a00e6061bab05c402d5aab2d12e7decebcd606c930d2029a93f2a46f8edbb188b73c7cdcad473b03c15037ea10e0b3538de0a99b1d7d7fb333
DIST qtpositioning-everywhere-src-6.6.1.tar.xz 1513456 BLAKE2B 174aa45f9fbe120c0b1ff675447b42fa4cee1f50c4bf0ad6a01bbb181fd5de79ad091a353770862cf829ba7442ca9ae039fa985caa68835cea6a82608e158f35 SHA512 8114d9cec0e453ff51fdbe8b1a814c968e614e1f9aaf031bf00c0c48e732de728d925852789360411c594f63ae322404fc9403d0bc3a35500522d8dc403d79e2
diff --git a/dev-qt/qtpositioning/qtpositioning-5.15.12.ebuild b/dev-qt/qtpositioning/qtpositioning-5.15.12.ebuild
new file mode 100644
index 000000000000..31a7a3b2ef14
--- /dev/null
+++ b/dev-qt/qtpositioning/qtpositioning-5.15.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QT5_MODULE="qtlocation"
+inherit qt5-build
+
+DESCRIPTION="Physical position determination library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+IUSE="geoclue +qml"
+
+RDEPEND="
+ =dev-qt/qtcore-${QT5_PV}*
+ geoclue? ( =dev-qt/qtdbus-${QT5_PV}* )
+ qml? ( =dev-qt/qtdeclarative-${QT5_PV}* )
+"
+DEPEND="${RDEPEND}"
+PDEPEND="
+ geoclue? ( app-misc/geoclue:2.0 )
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/positioning
+ src/plugins/position/positionpoll
+)
+
+pkg_setup() {
+ use geoclue && QT5_TARGET_SUBDIRS+=( src/plugins/position/geoclue2 )
+ use qml && QT5_TARGET_SUBDIRS+=(
+ src/positioningquick
+ src/imports/positioning
+ )
+}