summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-11 16:28:32 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-11 17:12:23 +0100
commit80b7d2109e04784cdedfc571054d3ed807d1eacc (patch)
tree3ef89abed89d19beb9002b8c697fbdaf17fa982c /dev-ros/amcl
parentdev-python/fonttools-3.44.0: alpha stable, bug 702026 (diff)
downloadgentoo-80b7d2109e04784cdedfc571054d3ed807d1eacc.tar.gz
gentoo-80b7d2109e04784cdedfc571054d3ed807d1eacc.tar.bz2
gentoo-80b7d2109e04784cdedfc571054d3ed807d1eacc.zip
dev-ros/amcl: Bump to 1.16.3.
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/amcl')
-rw-r--r--dev-ros/amcl/Manifest1
-rw-r--r--dev-ros/amcl/amcl-1.16.3.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/amcl/Manifest b/dev-ros/amcl/Manifest
index 67d0b9c053da..b8cb66a1191e 100644
--- a/dev-ros/amcl/Manifest
+++ b/dev-ros/amcl/Manifest
@@ -1,2 +1,3 @@
DIST navigation-1.16.1.tar.gz 336908 BLAKE2B 0f22db60352a0f50938ae18104ecad72c2e06eedeb2da8f6afe09bdc346868fcd71c90b0243c366b9fd0e7a26fef7551ab6a4febe87ab8d66af5ce3497c68770 SHA512 f6742f5afcaff2d1fc699e2695845b148bb16523e301f79577a8073fcc829541158b7c463f2e5bd9f69571f8b4042dbfacfe563de54b16193b5a31721c5f6faf
DIST navigation-1.16.2.tar.gz 337389 BLAKE2B a21d014df02ebf8046245777bb42fe3bccaf65af4c607532c4fb72e0b2c43870d1ff1c32c882a0418363708c0fa0c74925943beca2110a5f19b77a65e0a871fc SHA512 890eb391a8a70b3b17aa870dfa79bf48199cf3dcf7a8703b0e005b22ffd404edf723d73e30a04f902f436899fe321894bf3da7610f374b1a95b247629f64256e
+DIST navigation-1.16.3.tar.gz 342459 BLAKE2B 736414787adee9c7511b0d90276395d33b9b52207d55ddd53836c9d77cb6809bf1946443878ad83e4461d0febf05b616b93ec0a18b34ed402323eb9bbb100861 SHA512 2eddb27fd3eff143674cc518be520e6df4d24a965689441f710105977f4bbe307736df5e6303319dde99362187091ea4f90eaec9da5a4bc678250410af174a71
diff --git a/dev-ros/amcl/amcl-1.16.3.ebuild b/dev-ros/amcl/amcl-1.16.3.ebuild
new file mode 100644
index 000000000000..61525256fd54
--- /dev/null
+++ b/dev-ros/amcl/amcl-1.16.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Probabilistic localization system for a robot moving in 2D"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosbag
+ dev-libs/boost:=
+ dev-ros/roscpp
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_ros
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/python_orocos_kdl[${PYTHON_USEDEP}] dev-ros/map_server[${PYTHON_USEDEP}] )
+"