summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-26 19:13:49 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-26 19:29:30 +0200
commitb2987c0618650d92df3ca880cbd41a81d1b633cf (patch)
treeefbfda9986de2be4feaf50155d4bd3a24ddbdfca /dev-ros/diagnostic_updater/diagnostic_updater-1.9.0.ebuild
parentdev-ros/diagnostic_common_diagnostics: Bump to 1.9.0. (diff)
downloadgentoo-b2987c0618650d92df3ca880cbd41a81d1b633cf.tar.gz
gentoo-b2987c0618650d92df3ca880cbd41a81d1b633cf.tar.bz2
gentoo-b2987c0618650d92df3ca880cbd41a81d1b633cf.zip
dev-ros/diagnostic_updater: Bump to 1.9.0.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/diagnostic_updater/diagnostic_updater-1.9.0.ebuild')
-rw-r--r--dev-ros/diagnostic_updater/diagnostic_updater-1.9.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_updater/diagnostic_updater-1.9.0.ebuild b/dev-ros/diagnostic_updater/diagnostic_updater-1.9.0.ebuild
new file mode 100644
index 000000000000..f4bd878c1610
--- /dev/null
+++ b/dev-ros/diagnostic_updater/diagnostic_updater-1.9.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for updating diagnostics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest dev-ros/rostest[${PYTHON_USEDEP}] )"