summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-13 13:09:47 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-13 13:09:47 +0100
commit7bf8186077df64105f34820c492ce3a9714ead21 (patch)
tree980dcced7af44f5ca9541bf8e6783c8112bc3d95 /dev-ros/hector_geotiff/hector_geotiff-0.4.0.ebuild
parentdev-ros/hector_trajectory_server: Bump to 0.4.0. (diff)
downloadgentoo-7bf8186077df64105f34820c492ce3a9714ead21.tar.gz
gentoo-7bf8186077df64105f34820c492ce3a9714ead21.tar.bz2
gentoo-7bf8186077df64105f34820c492ce3a9714ead21.zip
dev-ros/hector_geotiff: Bump to 0.4.0.
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/hector_geotiff/hector_geotiff-0.4.0.ebuild')
-rw-r--r--dev-ros/hector_geotiff/hector_geotiff-0.4.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/hector_geotiff/hector_geotiff-0.4.0.ebuild b/dev-ros/hector_geotiff/hector_geotiff-0.4.0.ebuild
new file mode 100644
index 000000000000..7a60491232d1
--- /dev/null
+++ b/dev-ros/hector_geotiff/hector_geotiff-0.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Node to save occupancy grid map, robot trajectory and object of interest data to GeoTiff images"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/hector_map_tools
+ dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-libs/console_bridge:=
+ dev-ros/roscpp
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"
+
+PATCHES=( "${FILESDIR}/qt5.patch" )