summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-28 19:24:21 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-28 20:10:38 +0100
commitd2587f2b358f747c56a9802a67ff6ae546549ed9 (patch)
treeb84159d88a233c3f8b59687b95cc01149a40d2b1 /dev-ros/libmavconn/libmavconn-0.19.0-r1.ebuild
parentdev-ros/libmavconn: Remove old (diff)
downloadgentoo-d2587f2b358f747c56a9802a67ff6ae546549ed9.tar.gz
gentoo-d2587f2b358f747c56a9802a67ff6ae546549ed9.tar.bz2
gentoo-d2587f2b358f747c56a9802a67ff6ae546549ed9.zip
dev-ros/libmavconn: add missing dep on console bridge
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ros/libmavconn/libmavconn-0.19.0-r1.ebuild')
-rw-r--r--dev-ros/libmavconn/libmavconn-0.19.0-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/libmavconn/libmavconn-0.19.0-r1.ebuild b/dev-ros/libmavconn/libmavconn-0.19.0-r1.ebuild
new file mode 100644
index 000000000000..9eb27fcc7ea7
--- /dev/null
+++ b/dev-ros/libmavconn/libmavconn-0.19.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/mavlink/mavros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="MAVLink communication library"
+LICENSE="GPL-3 LGPL-3 BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/mavlink-gbp-release-2016.7.7
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"