summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-14 12:46:38 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-14 12:46:38 +0100
commit364c71e6961214988870c87b34c402b52f5eb098 (patch)
tree16077100412fc62d8423167fde0b7e0424e6c7e6 /dev-ros/rospack
parentdev-python/rosdistro: bump to 0.4.5 (diff)
downloadgentoo-364c71e6961214988870c87b34c402b52f5eb098.tar.gz
gentoo-364c71e6961214988870c87b34c402b52f5eb098.tar.bz2
gentoo-364c71e6961214988870c87b34c402b52f5eb098.zip
dev-ros/rospack: bump to 2.2.6
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rospack')
-rw-r--r--dev-ros/rospack/Manifest1
-rw-r--r--dev-ros/rospack/rospack-2.2.6.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/rospack/Manifest b/dev-ros/rospack/Manifest
index 80fef923bfed..c51f4da6631e 100644
--- a/dev-ros/rospack/Manifest
+++ b/dev-ros/rospack/Manifest
@@ -1 +1,2 @@
DIST rospack-2.2.5.tar.gz 70273 SHA256 8602e21172ef453b63c6c6f1698c5ac81ec014b0a78bf98f31a60937dacee9ef SHA512 b685029e7306795459a1768050fd54e3eb82db91c0c3495410eeb6c6b3cb24b5d7f63cc5286d466659edb35719e76e4a43519526fd0c991fef2d7f9e092fd9e0 WHIRLPOOL 33191188ef39f817f48cdfbda407dc4d4bf288920b7e7b9a1b4b9ff383b87781a34fe7a3bfe734c8431c9e2cde19cadff1d70d84129de813bfbf2412a5728835
+DIST rospack-2.2.6.tar.gz 70391 SHA256 3487f24bd5362fa9a0c44b145543e13d7aa20bdb19d0477b7872d52a11bef914 SHA512 3257007600fc7509c276dcdf8484c91f44e10fad988e62f227b0471cf77f41464712ec8e0f31141853d5b8fa863f701451adae10a5ea3ae7bdd4a96910e5ea28 WHIRLPOOL 026dbe2966305f67ae42959d7677c9fcbeffcc740f8bcb9207b1adfc0bbd45259dc7b1789566b7cffad4b61510efbcc172a4544ec76e43548b0209f4f0b13991
diff --git a/dev-ros/rospack/rospack-2.2.6.ebuild b/dev-ros/rospack/rospack-2.2.6.ebuild
new file mode 100644
index 000000000000..44ef9df841d0
--- /dev/null
+++ b/dev-ros/rospack/rospack-2.2.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/rospack"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+# Do it that way to avoid ros-catkin pulling in python-r1
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit python-single-r1
+
+DESCRIPTION="Retrieves information about ROS packages available on the filesystem"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:=
+ dev-libs/tinyxml
+ "
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? (
+ dev-cpp/gtest
+ dev-python/nose
+ )"