summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-03 11:56:46 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-03 12:50:32 +0200
commit6576e2d84a673af7ac7514b33085e5e9305a65da (patch)
treef13b9288673a282ffce4fb2bf586d972918c1c60 /dev-ros/topic_tools/topic_tools-1.15.11.ebuild
parentdev-ros/rostopic: Bump to 1.15.11. (diff)
downloadgentoo-6576e2d84a673af7ac7514b33085e5e9305a65da.tar.gz
gentoo-6576e2d84a673af7ac7514b33085e5e9305a65da.tar.bz2
gentoo-6576e2d84a673af7ac7514b33085e5e9305a65da.zip
dev-ros/topic_tools: Bump to 1.15.11.
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/topic_tools/topic_tools-1.15.11.ebuild')
-rw-r--r--dev-ros/topic_tools/topic_tools-1.15.11.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ros/topic_tools/topic_tools-1.15.11.ebuild b/dev-ros/topic_tools/topic_tools-1.15.11.ebuild
new file mode 100644
index 000000000000..56e95ed254bf
--- /dev/null
+++ b/dev-ros/topic_tools/topic_tools-1.15.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=tools/${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for directing, throttling and selecting ROS topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rostime
+ dev-ros/xmlrpcpp
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosbash[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostopic[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_SINGLE_USEDEP}]
+ dev-cpp/gtest
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"