summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-10-27 15:17:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2022-10-27 16:05:15 +0200
commit42102712fd8fd158182c5f772751705884e2bd1d (patch)
tree8cf99b04de6da215b750967f1ca090f8248a8ea4 /dev-ros
parentros-meta/image_pipeline: Bump to 1.17.0. (diff)
downloadgentoo-42102712fd8fd158182c5f772751705884e2bd1d.tar.gz
gentoo-42102712fd8fd158182c5f772751705884e2bd1d.tar.bz2
gentoo-42102712fd8fd158182c5f772751705884e2bd1d.zip
dev-ros/cv_bridge: Bump to 1.16.2.
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/cv_bridge/Manifest1
-rw-r--r--dev-ros/cv_bridge/cv_bridge-1.16.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/cv_bridge/Manifest b/dev-ros/cv_bridge/Manifest
index ec3c38f8fb88..8be5317dbe30 100644
--- a/dev-ros/cv_bridge/Manifest
+++ b/dev-ros/cv_bridge/Manifest
@@ -1 +1,2 @@
DIST vision_opencv-1.16.0.tar.gz 85452 BLAKE2B 5f167898cef4bbc753e32af87174b7f668b3eff00357a22e8c454d181116a925059d4837210086d445ceaf74819fdb9a527eb5667321df8a7c1fe84549dbe5b6 SHA512 affd61f0d933cc57d5d23e840f0708e8ffdc0033eee22a21fe5c0099a2ab75d4c3fdcc41705167ab3615f5388ce47641faf5b21e6c6365a4e540abe69dfad3fe
+DIST vision_opencv-1.16.2.tar.gz 86615 BLAKE2B e3078be4a865aed4317db7dc422a71661a52e8b42c52aaab92c524cdb14ad08ab85ac523d55b76b5ebc6201400a832d0ea9c3203ed5ff2af342a58be5ab0ef49 SHA512 c1fd4b402cc970797c0b01573d111cec041ea59598897256ed26ad01624e15300cc2147deaf701af1d12bc921ac9892917d927d17325d4086c0724633d96b3c5
diff --git a/dev-ros/cv_bridge/cv_bridge-1.16.2.ebuild b/dev-ros/cv_bridge/cv_bridge-1.16.2.ebuild
new file mode 100644
index 000000000000..b1563eb9a061
--- /dev/null
+++ b/dev-ros/cv_bridge/cv_bridge-1.16.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Converts between ROS Image messages and OpenCV images"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosconsole
+ >=media-libs/opencv-3:=[contrib(+),png,jpeg,tiff]
+ $(python_gen_cond_dep "dev-libs/boost:=[python,\${PYTHON_USEDEP}]")
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? (
+ dev-cpp/gtest
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ )
+"
+PATCHES=( "${FILESDIR}/boostpython.patch" "${FILESDIR}/ocv_leak.patch" )