summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-05-08 07:49:39 +0200
committerHans de Graaff <graaff@gentoo.org>2022-05-08 07:49:47 +0200
commit348a495d3f551d80a545282239d3846e627165d7 (patch)
tree5dd3b9b725d697c514f05ae69c5e4f27bad54d28 /dev-ruby/autoprefixer-rails
parentdev-ruby/asciimath: add 2.0.4 (diff)
downloadgentoo-348a495d3f551d80a545282239d3846e627165d7.tar.gz
gentoo-348a495d3f551d80a545282239d3846e627165d7.tar.bz2
gentoo-348a495d3f551d80a545282239d3846e627165d7.zip
dev-ruby/autoprefixer-rails: add 10.4.7.0
Also add missing sprockets-rails dependency. Closes: https://bugs.gentoo.org/723660 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/autoprefixer-rails')
-rw-r--r--dev-ruby/autoprefixer-rails/Manifest1
-rw-r--r--dev-ruby/autoprefixer-rails/autoprefixer-rails-10.4.7.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/autoprefixer-rails/Manifest b/dev-ruby/autoprefixer-rails/Manifest
index 018f69727b52..7665c3992e4e 100644
--- a/dev-ruby/autoprefixer-rails/Manifest
+++ b/dev-ruby/autoprefixer-rails/Manifest
@@ -1,3 +1,4 @@
DIST autoprefixer-rails-10.3.1.0.tar.gz 1357327 BLAKE2B 2071b3a9c5848e06695e32445224f6e101481fac0ca73a23b86d138bfada9f7339bd51031f121ab8b0f614d2ea1ec386cb81dbbcf8f728075b12ff2393c0c8b5 SHA512 fff90cad950228e9d3b61259f26bee26b2fe3cd87557ed81f1235630357204e3cf9ce6cc9439551727d4d62d27f3510c8c2683ab12b05ad11549945f741e5db5
DIST autoprefixer-rails-10.4.2.0.tar.gz 1368753 BLAKE2B b5c9374f6161f9f13f78404788cdba60d88f50f68f909cead6cb5389a4f26f05cdd20925cf91d9a0b01af0ce14929b11d69f85a1ce8493c660c50c6032460a0c SHA512 00303b7dec4b261b2d3ffa72ebdfea2883cb473df3f8149853b0d2fcb5c2e48d63e24a17604619289893d0472afe237f1dc13710d2c7c3528067c143789abf61
+DIST autoprefixer-rails-10.4.7.0.tar.gz 1372138 BLAKE2B 5d4ad1cb82fc0e82557232fc1a050f87fc2758967c21e2e566049686efec41b599e3cf7e2b432d164c6a29c2463ab3c695703878c23188ee97a46e5aff6a26a2 SHA512 c1d3a1200c05a3b1219716058eb28babef4bc26eaca1ebdc09a901709435f25f097d3c39398a07283a75ed37b30a45398fbe31095e649f6d94fdc6de2346aad6
DIST autoprefixer-rails-9.8.6.5.gem 231936 BLAKE2B 7c702f5484f9aa2318408fb8c5c8866ccf9d3565d3282e43279b9bea875ac3610b26c0ec302b2bed0779dcd46eca12badaa16faba1046585cddcfa3e8b22b51c SHA512 6b7281661fcaf0c17ee258a321f8d18664f2f305172719f76fe1f3ef6b04fa1460c7102946e95153df7ecf5c3ade3bfc8c22d302927f2e2183ef3b0f3ef8d623
diff --git a/dev-ruby/autoprefixer-rails/autoprefixer-rails-10.4.7.0.ebuild b/dev-ruby/autoprefixer-rails/autoprefixer-rails-10.4.7.0.ebuild
new file mode 100644
index 000000000000..1e2a93be0a5d
--- /dev/null
+++ b/dev-ruby/autoprefixer-rails/autoprefixer-rails-10.4.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="vendor"
+
+RUBY_FAKEGEM_GEMSPEC="autoprefixer-rails.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Add vendor prefixes to CSS rules using values from the Can I Use website"
+HOMEPAGE="https://github.com/ai/autoprefixer-rails"
+SRC_URI="https://github.com/ai/autoprefixer-rails/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/execjs"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rails-5.0.0
+ dev-ruby/rake
+ dev-ruby/rspec-rails
+ dev-ruby/sprockets-rails
+)"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" -e "/BUNDLE/d" spec/app/config/boot.rb || die
+ sed -i -e "/Bundler/ s:^:#:" \
+ -e '/config.sass/ s:^:#:' spec/app/config/application.rb || die
+ rm -f spec/rails_spec.rb || die
+}