summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-03-13 07:29:06 +0100
committerHans de Graaff <graaff@gentoo.org>2024-03-14 06:48:37 +0100
commitbf4122917692eb5864dc8424796469bbb4a1a7c7 (patch)
tree2691756416835719e8fc775cf6032bdbb56be030 /dev-ruby/certificate_authority
parentdev-ruby/http: add 5.2.0 (diff)
downloadgentoo-bf4122917692eb5864dc8424796469bbb4a1a7c7.tar.gz
gentoo-bf4122917692eb5864dc8424796469bbb4a1a7c7.tar.bz2
gentoo-bf4122917692eb5864dc8424796469bbb4a1a7c7.zip
dev-ruby/certificate_authority: enable ruby33
Closes: https://bugs.gentoo.org/923348 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/certificate_authority')
-rw-r--r--dev-ruby/certificate_authority/certificate_authority-1.1.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-ruby/certificate_authority/certificate_authority-1.1.0.ebuild b/dev-ruby/certificate_authority/certificate_authority-1.1.0.ebuild
index 173bf6c75e31..f071d6a0c5b4 100644
--- a/dev-ruby/certificate_authority/certificate_authority-1.1.0.ebuild
+++ b/dev-ruby/certificate_authority/certificate_authority-1.1.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
@@ -20,7 +20,6 @@ SRC_URI="https://github.com/cchandler/certificate_authority/archive/v${PV}.tar.g
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
all_ruby_prepare() {
sed -i -e '/\(bundler\|pry\|overalls\)/ s:^:#:' spec/spec_helper.rb || die
@@ -30,4 +29,7 @@ all_ruby_prepare() {
# make work on different arches due to hardwired load paths in
# specs.
rm -f spec/units/pkcs11_key_material_spec.rb || die
+
+ # Fix spec for OpenSSL 3.x
+ sed -i -e '426 s/keyid://' spec/units/certificate_spec.rb || die
}