summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-03-25 08:34:43 +0100
committerHans de Graaff <graaff@gentoo.org>2023-03-26 08:29:42 +0200
commitab4917780ca7e93afc1ecf2fba8d4dd2021f9ed9 (patch)
treea2a77a7b5671f84b2ad12e56308a6ddd0243781a /dev-ruby/connection_pool
parentmedia-plugins/libvisual-projectm: Stabilize 2.1.1 amd64, #903105 (diff)
downloadgentoo-ab4917780ca7e93afc1ecf2fba8d4dd2021f9ed9.tar.gz
gentoo-ab4917780ca7e93afc1ecf2fba8d4dd2021f9ed9.tar.bz2
gentoo-ab4917780ca7e93afc1ecf2fba8d4dd2021f9ed9.zip
dev-ruby/connection_pool: add 2.4.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/connection_pool')
-rw-r--r--dev-ruby/connection_pool/Manifest1
-rw-r--r--dev-ruby/connection_pool/connection_pool-2.4.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/connection_pool/Manifest b/dev-ruby/connection_pool/Manifest
index 3e6955376efe..27e4ac7a4de7 100644
--- a/dev-ruby/connection_pool/Manifest
+++ b/dev-ruby/connection_pool/Manifest
@@ -1,2 +1,3 @@
DIST connection_pool-2.2.5.gem 14848 BLAKE2B d3e21e5d3c330fb501e9890260c0fed003f3c8afc6a9106c139f77e879c45232de1cbc16be6088c757a1204f3c64b0797010fddc0d1c9cf555389348b6f61152 SHA512 3bc4e4d241cd4b1adb00d341aafe7795bbf0eff459ace962670d83c20c0eaa0d42f49a1f5e61c2327ff4fcbf3abfbc6f6c910f7a31d4a0f62bc55c782ab20e45
DIST connection_pool-2.3.0.tar.gz 10656 BLAKE2B 235ddcf6956c53bff276c27b47f3dd21f008cad4eea07692cad186117e6d6a986acb1fa1e2eeb29a9bb72f5ee5e3b7c80927e711ebdf00ceec9af2f02ca37e25 SHA512 8f9c9c1c738b5321b52c28033bb7ac8f6697edfe584f858ce4891514c65730ccb950db9136f059991c4fe1d1386b18883d7b61557aeeb687c602a09229dcb38f
+DIST connection_pool-2.4.0.tar.gz 11243 BLAKE2B b8fcb164473863dfa4d4cd0a2f511f006ab0369a3890639115b42755eb6a50f1e8e37e1b2bdba0a4ac203ef05e5fde84cc95b0f10f547b56effbaa19df0ee64e SHA512 7b3d732da657ecdd1ebe2fa1600c0d723496be9c89397db3da06d854daba07aa959750527ec2c08bdf5a41e30df2ee04407fe76260440848db9b426c508a3544
diff --git a/dev-ruby/connection_pool/connection_pool-2.4.0.ebuild b/dev-ruby/connection_pool/connection_pool-2.4.0.ebuild
new file mode 100644
index 000000000000..dbb4aafbffa5
--- /dev/null
+++ b/dev-ruby/connection_pool/connection_pool-2.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_GEMSPEC="connection_pool.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changes.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generic connection pooling for Ruby"
+HOMEPAGE="https://github.com/mperham/connection_pool"
+SRC_URI="https://github.com/mperham/connection_pool/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' connection_pool.gemspec || die
+ sed -i -e '/\(bundler\|standard\)/ s:^:#:' Rakefile || die
+ sed -i -e "s/gem 'minitest'/gem 'minitest', '~> 5.0'/" test/helper.rb || die
+}