summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-08-15 06:32:32 +0200
committerHans de Graaff <graaff@gentoo.org>2021-08-15 09:41:13 +0200
commited542eb591f1105e1b03f6088d1ca4f36fe46fa4 (patch)
tree03cfd886465e5b0efa1b65b75c8f8f3256aede73 /dev-ruby/curb
parentdev-ruby/bundler: add 2.2.25 (diff)
downloadgentoo-ed542eb591f1105e1b03f6088d1ca4f36fe46fa4.tar.gz
gentoo-ed542eb591f1105e1b03f6088d1ca4f36fe46fa4.tar.bz2
gentoo-ed542eb591f1105e1b03f6088d1ca4f36fe46fa4.zip
dev-ruby/curb: avoid test requiring ntlm
net-misc/curl in Gentoo no longer supports ntlm so this test now fails. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/curb')
-rw-r--r--dev-ruby/curb/curb-0.9.11-r1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-ruby/curb/curb-0.9.11-r1.ebuild b/dev-ruby/curb/curb-0.9.11-r1.ebuild
index bf0097fb81a3..c3928cceda46 100644
--- a/dev-ruby/curb/curb-0.9.11-r1.ebuild
+++ b/dev-ruby/curb/curb-0.9.11-r1.ebuild
@@ -19,7 +19,7 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE=""
-DEPEND+=" net-misc/curl[ssl]"
+DEPEND+=" net-misc/curl[ssl] test? ( net-misc/curl[samba] )"
RDEPEND+=" net-misc/curl[ssl]"
all_ruby_prepare() {
@@ -39,4 +39,7 @@ all_ruby_prepare() {
# avoid failing tests where failure condition seems weird, no
# upstream travis so not clear if the test is indeed broken.
sed -i -e '/test_multi_easy_http/,/^ end/ s:^:#:' tests/tc_curl_multi.rb || die
+
+ # avoid test requiring ntlm support on curl which is no longer available in gentoo
+ sed -i -e '/test_username_password/aomit "ntlm support in curl needed"' -i tests/tc_curl_easy.rb || die
}