summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/erubis
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/erubis')
-rw-r--r--dev-ruby/erubis/Manifest1
-rw-r--r--dev-ruby/erubis/erubis-2.7.0-r1.ebuild56
-rw-r--r--dev-ruby/erubis/erubis-2.7.0-r2.ebuild40
-rw-r--r--dev-ruby/erubis/metadata.xml5
4 files changed, 102 insertions, 0 deletions
diff --git a/dev-ruby/erubis/Manifest b/dev-ruby/erubis/Manifest
new file mode 100644
index 000000000000..297d85260a45
--- /dev/null
+++ b/dev-ruby/erubis/Manifest
@@ -0,0 +1 @@
+DIST erubis-2.7.0.gem 173056 SHA256 63653f5174a7997f6f1d6f465fbe1494dcc4bdab1fb8e635f6216989fb1148ba SHA512 49b08b28656acaf3b0c88fe064bb0d5f79fd08b834d7eba9294217b0893c5a0244ac5dd54de0e52dd17e828a0110e54b29e8c2d75171d527da957917344a0f27 WHIRLPOOL f58bbb85bcd4182eb0301ead30138b948322015df6853e2ca2ea272dfda20c980108b032f29d1304e2bb17dd4b0ee22fb69e57f374588fac2428d5ea4df4dfff
diff --git a/dev-ruby/erubis/erubis-2.7.0-r1.ebuild b/dev-ruby/erubis/erubis-2.7.0-r1.ebuild
new file mode 100644
index 000000000000..3410835811e5
--- /dev/null
+++ b/dev-ruby/erubis/erubis-2.7.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Erubis is an implementation of eRuby"
+HOMEPAGE="http://www.kuwata-lab.com/erubis/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/abstract-1.0.0"
+
+all_ruby_prepare() {
+ # These tests now fail due to other ordering and fact that sym
+ # are now returned.
+ rm test/test-users-guide.rb || die
+ sed -i -e '/test-users-guide/ s:^:#:' test/test.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Avoid test on jruby that fails different on syntax error.
+ sed -i -e '/test_syntax2/,/^ end/ s:^:#:' test/test-main.rb || die
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ # http://rubyforge.org/tracker/index.php?func=detail&aid=29484&group_id=1320&atid=5201
+ *ruby19)
+ einfo "Tests are not compatible with ruby 1.9.3 with Psych as YAML module."
+ ;;
+ *ruby20)
+ einfo "Tests are not compatible with ruby 2.0.0 with Psych as YAML module."
+ ;;
+ *)
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -I. test/test.rb || die
+ ;;
+ esac
+}
diff --git a/dev-ruby/erubis/erubis-2.7.0-r2.ebuild b/dev-ruby/erubis/erubis-2.7.0-r2.ebuild
new file mode 100644
index 000000000000..77f406da7615
--- /dev/null
+++ b/dev-ruby/erubis/erubis-2.7.0-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Erubis is an implementation of eRuby"
+HOMEPAGE="http://www.kuwata-lab.com/erubis/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# http://rubyforge.org/tracker/index.php?func=detail&aid=29484&group_id=1320&atid=5201
+# Tests are not compatible with Psych as YAML module.
+RESTRICT="test"
+
+ruby_add_rdepend ">=dev-ruby/abstract-1.0.0"
+
+all_ruby_prepare() {
+ # These tests now fail due to other ordering and fact that sym
+ # are now returned.
+ rm test/test-users-guide.rb || die
+ sed -i -e '/test-users-guide/ s:^:#:' test/test.rb || die
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -I. test/test.rb || die
+}
diff --git a/dev-ruby/erubis/metadata.xml b/dev-ruby/erubis/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/erubis/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>