summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-04-10 06:46:30 +0200
committerHans de Graaff <graaff@gentoo.org>2022-04-10 06:46:30 +0200
commit62bbfc14bc6bce663a933b5d3843e09d78dd85c8 (patch)
treefd375e5f9ab360b34b951daefce1b853aabf9074 /dev-ruby/flog
parentdev-ruby/path_expander: enable ruby31 and disable ruby25 (diff)
downloadgentoo-62bbfc14bc6bce663a933b5d3843e09d78dd85c8.tar.gz
gentoo-62bbfc14bc6bce663a933b5d3843e09d78dd85c8.tar.bz2
gentoo-62bbfc14bc6bce663a933b5d3843e09d78dd85c8.zip
dev-ruby/flog: add 4.6.5
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/flog')
-rw-r--r--dev-ruby/flog/Manifest1
-rw-r--r--dev-ruby/flog/flog-4.6.5.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/flog/Manifest b/dev-ruby/flog/Manifest
index 60d33583b887..698f560d180c 100644
--- a/dev-ruby/flog/Manifest
+++ b/dev-ruby/flog/Manifest
@@ -1 +1,2 @@
DIST flog-4.6.4.gem 26624 BLAKE2B 27090f9a47619b63c8c34e0d6992c1d0ff29193a7de3af839d72d5754c2b149f38c1c1e3caec981170c408123bc38e3fc3e38e87fb9a83818e1cb356d31070c3 SHA512 495601bfc560c2d18973234c41706aa07b76ea95bc3803f93fb16b42ae071b65fc9a1c36e8d4a9bfaf3c88a1167ab714f4bbc7a982b9e606aa799f8480a23f4d
+DIST flog-4.6.5.gem 26624 BLAKE2B c1cf4377be7a2b9856e4f370b6a559ac1ebac6aba7da28bd6a27bb84fe8df613680cb7c96e3d30e42d30011b97309c60e7f4bec2c322bcc3b2ed8ad5f93172a1 SHA512 81eaf3871f6111b442fb82371720709073f00a17044885e85498e7f943e1c9f8b5345ae8ff06a56ff68db8919ee0e696284bf017b1e1e66d76419306bed90866
diff --git a/dev-ruby/flog/flog-4.6.5.ebuild b/dev-ruby/flog/flog-4.6.5.ebuild
new file mode 100644
index 000000000000..b2b88b559e64
--- /dev/null
+++ b/dev-ruby/flog/flog-4.6.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Flog reports the most tortured code in an easy to read pain report"
+HOMEPAGE="https://ruby.sadi.st/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+ruby_add_rdepend "
+ dev-ruby/path_expander:1
+ >dev-ruby/ruby_parser-3.1.0:3
+ >=dev-ruby/sexp_processor-4.8:4"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_flog.rb || die
+}