summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-12-25 07:22:43 +0100
committerHans de Graaff <graaff@gentoo.org>2020-12-25 08:12:56 +0100
commit0edb73a350e33ef234f8fa4bbabe9b9b8176ac60 (patch)
tree22edc86ee75b18d377bd08278cacf05e02aaf6aa /dev-ruby/http-parser/http-parser-1.2.2.ebuild
parentdev-ruby/ffi-compiler: initial import of 1.0.1 (diff)
downloadgentoo-0edb73a350e33ef234f8fa4bbabe9b9b8176ac60.tar.gz
gentoo-0edb73a350e33ef234f8fa4bbabe9b9b8176ac60.tar.bz2
gentoo-0edb73a350e33ef234f8fa4bbabe9b9b8176ac60.zip
dev-ruby/http-parser: initial import of 1.2.2
New dependency for dev-ruby/http. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/http-parser/http-parser-1.2.2.ebuild')
-rw-r--r--dev-ruby/http-parser/http-parser-1.2.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/http-parser/http-parser-1.2.2.ebuild b/dev-ruby/http-parser/http-parser-1.2.2.ebuild
new file mode 100644
index 000000000000..796554e18319
--- /dev/null
+++ b/dev-ruby/http-parser/http-parser-1.2.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A super fast http parser for ruby"
+HOMEPAGE="https://github.com/cotag/http-parser"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" >=net-libs/http-parser-2.8.1"
+RDEPEND+=" >=net-libs/http-parser-2.8.1"
+
+ruby_add_bdepend "dev-ruby/ffi-compiler"
+
+each_ruby_compile() {
+ ${RUBY} -C ext -S rake || die
+ mv ext/x86_64-linux/libhttp-parser-ext.so lib/http-parser/ || die
+}