summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-04-01 08:09:07 +0200
committerHans de Graaff <graaff@gentoo.org>2016-04-01 08:09:07 +0200
commitd93305702a73adc1796b35de1a7a3a5242eb54d7 (patch)
treedd2a5d8881d415fcefed270d01f9569c1d54e58e /dev-ruby/jmespath
parentmedia-video/mkvtoolnix: bump to 9.0.1 (diff)
downloadgentoo-d93305702a73adc1796b35de1a7a3a5242eb54d7.tar.gz
gentoo-d93305702a73adc1796b35de1a7a3a5242eb54d7.tar.bz2
gentoo-d93305702a73adc1796b35de1a7a3a5242eb54d7.zip
dev-ruby/jmespath: add 1.2.2
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/jmespath')
-rw-r--r--dev-ruby/jmespath/Manifest1
-rw-r--r--dev-ruby/jmespath/jmespath-1.2.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/jmespath/Manifest b/dev-ruby/jmespath/Manifest
index 2d6562e675d6..6e7ef0c77977 100644
--- a/dev-ruby/jmespath/Manifest
+++ b/dev-ruby/jmespath/Manifest
@@ -1 +1,2 @@
DIST jmespath-1.1.3.tar.gz 34314 SHA256 2c987327ab21bdab28b310cd3696af9cdf2e6264b0174ee40ecfd26d855c02b4 SHA512 ea76eb9fcda4cae9a874d120c81c9dc6bea0a7988287a88c9dabedc3755c9ce3ccea7a485de76d00a0e010f4f534fefa6acc99f865e370c7788b40ec10181fcf WHIRLPOOL aec4eb9fb25026e43de99da4403a12db170a9b841c5cd40d38f6a01acc4574eed9c798a57fd19c8991838d9009ccda62c701154689e8157f29e9546d3752e020
+DIST jmespath-1.2.2.tar.gz 38801 SHA256 0425a2b8e39f129edd0827cfa995a4e5176dc6af7dc702b7f2474ab91951bab1 SHA512 4af9cf3100b31304428cf7bea4d479157a08504b6a19e045aa9f52c45f591563fa9e18f385ae8fb24783e20756ad4bebf62c50e4d7b08f932661f2e77e2cb824 WHIRLPOOL d59fc2de76188a3739a5cf60111ef1230978034e83637ad2c8fedea5b8842358b8b00c17fbc18402611fd96d045e4e7a0cee04279e0a39c8b31a858bb7d1ac3f
diff --git a/dev-ruby/jmespath/jmespath-1.2.2.ebuild b/dev-ruby/jmespath/jmespath-1.2.2.ebuild
new file mode 100644
index 000000000000..e6d7fd1187ad
--- /dev/null
+++ b/dev-ruby/jmespath/jmespath-1.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements JMESPath for Ruby"
+HOMEPAGE="https://github.com/jmespath/jmespath.rb"
+SRC_URI="https://github.com/jmespath/jmespath.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}.rb-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' \
+ spec/{compliance_spec,compliance_without_errors_spec,spec_helper}.rb || die
+}