summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-12-26 09:13:12 +0100
committerHans de Graaff <graaff@gentoo.org>2023-12-26 16:52:46 +0100
commit8eb7d61f4b954c3a7864d75b0cfcc4b50b727c12 (patch)
treeeb53256566dff74f8db5ef3a83b3c48a42982690 /dev-ruby/json
parentdev-ruby/psych: enable ruby33 (diff)
downloadgentoo-8eb7d61f4b954c3a7864d75b0cfcc4b50b727c12.tar.gz
gentoo-8eb7d61f4b954c3a7864d75b0cfcc4b50b727c12.tar.bz2
gentoo-8eb7d61f4b954c3a7864d75b0cfcc4b50b727c12.zip
dev-ruby/json: enable ruby33
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/json-2.7.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-ruby/json/json-2.7.1.ebuild b/dev-ruby/json/json-2.7.1.ebuild
index 89d650801018..178fac808b33 100644
--- a/dev-ruby/json/json-2.7.1.ebuild
+++ b/dev-ruby/json/json-2.7.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby31 ruby32"
+USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
RUBY_FAKEGEM_DOCDIR="doc"
@@ -42,6 +42,9 @@ all_ruby_prepare() {
-e 's|`git ls-files`|""|' \
Rakefile || die "rakefile fix failed"
+ sed -e 's/__dir__/"."/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+
# Avoid setting gem since it will not be available yet when installing
sed -i -e '/gem/ s:^:#:' tests/test_helper.rb || die
}