summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-03 01:08:16 +0100
committerSam James <sam@gentoo.org>2023-04-03 01:46:31 +0100
commit49a6bab711e4287028759ff29b4cc3f2184f230b (patch)
tree13c71516fb2bcba87a18b0c3f589db5cc2d9ef78 /dev-ruby/localhost
parentdev-ruby/async-process: new package, add 1.3.1 (diff)
downloadgentoo-49a6bab711e4287028759ff29b4cc3f2184f230b.tar.gz
gentoo-49a6bab711e4287028759ff29b4cc3f2184f230b.tar.bz2
gentoo-49a6bab711e4287028759ff29b4cc3f2184f230b.zip
dev-ruby/localhost: add 1.1.10
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/localhost')
-rw-r--r--dev-ruby/localhost/Manifest1
-rw-r--r--dev-ruby/localhost/localhost-1.1.10.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/localhost/Manifest b/dev-ruby/localhost/Manifest
index ed63740a7d32..8e95559775d1 100644
--- a/dev-ruby/localhost/Manifest
+++ b/dev-ruby/localhost/Manifest
@@ -1 +1,2 @@
+DIST localhost-1.1.10.tar.gz 2128142 BLAKE2B 06e4ab07bc273b8beba5fb3ee3f64e171a6c4a2e944c6d5e432417560283230277213732bf23ddd12e9737b2803582a11fdaa76356d14d2bdbd4e90d402c6204 SHA512 946ef247b256165cf5c849a32c0ba8dd2007164bd1549a20aca595328174709e9213ba8a98448dc41a57558b00147c3b7428b7bc625059ab24f89c94ff8850e9
DIST localhost-1.1.9.tar.gz 2125545 BLAKE2B 5843b3857a11d9f56412f67cb15e424332b07cf81a29ae0a05a3ff20c6f06af56f6a02d8315f97c2d57fe76f7359c737cf19f116868ff532ac083070430fa22e SHA512 d46fd016957fd34309d50488dc61f23e9d47a5a6bfdeda5c049f6ffc112c13cd21394ada3e15c56f14913cba6ab503f60e32237431f7ff824fbbab8cd8a2d746
diff --git a/dev-ruby/localhost/localhost-1.1.10.ebuild b/dev-ruby/localhost/localhost-1.1.10.ebuild
new file mode 100644
index 000000000000..f061baa1a9e2
--- /dev/null
+++ b/dev-ruby/localhost/localhost-1.1.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="readme.md"
+RUBY_FAKEGEM_GEMSPEC="localhost.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="sus"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Manage a local CA for self-signed localhost development servers"
+HOMEPAGE="https://github.com/socketry/localhost"
+SRC_URI="https://github.com/socketry/localhost/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+
+ruby_add_bdepend "test? ( dev-ruby/sus-fixtures-async )"
+
+all_ruby_prepare() {
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/covered/Id' config/sus.rb || die
+}
+
+each_ruby_test() {
+ # Tests fail in parallel as it tries to use the same port so
+ # manually replicate ruby-ng_sus for now, as ruby-ng_sus runs sus-parallel.
+ ${RUBY} -S sus || die
+}