summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-03-23 06:37:00 +0100
committerHans de Graaff <graaff@gentoo.org>2018-03-23 06:37:00 +0100
commit3887ef3b5d68ff7638db953cc11692a40c5afdd6 (patch)
tree788c1e7a08c78abe3470b6e33b921d809a104d80 /dev-ruby/loofah/loofah-2.2.2.ebuild
parentapp-arch/lz4: arm stable, bug #643032 (diff)
downloadgentoo-3887ef3b5d68ff7638db953cc11692a40c5afdd6.tar.gz
gentoo-3887ef3b5d68ff7638db953cc11692a40c5afdd6.tar.bz2
gentoo-3887ef3b5d68ff7638db953cc11692a40c5afdd6.zip
dev-ruby/loofah: add 2.2.2
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/loofah/loofah-2.2.2.ebuild')
-rw-r--r--dev-ruby/loofah/loofah-2.2.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/loofah/loofah-2.2.2.ebuild b/dev-ruby/loofah/loofah-2.2.2.ebuild
new file mode 100644
index 000000000000..aaf05c90a3f1
--- /dev/null
+++ b/dev-ruby/loofah/loofah-2.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for manipulating and transforming HTML/XML documents and fragments."
+HOMEPAGE="https://github.com/flavorjones/loofah"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/crass-1.0* >=dev-ruby/crass-1.0.2 >=dev-ruby/nokogiri-1.5.9"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rr-1.1.0 >=dev-ruby/hoe-2.3.0 )"
+
+all_ruby_prepare() {
+ # Avoid unneeded development dependencies
+ sed -i -e '/concourse/I s:^:#:' Rakefile || die
+
+ # Avoid test failing on different whitespace.
+ sed -i -e '/test_fragment_whitewash_on_microsofty_markup/askip "gentoo"' test/integration/test_ad_hoc.rb || die
+}