summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-06-29 22:03:00 +0200
committerHans de Graaff <graaff@gentoo.org>2023-06-29 22:13:52 +0200
commit645f2d11a2374cd960c7e80cf871873341eb369a (patch)
tree5f8ad97cd31c674b04a2797414753d5d83475cea /dev-ruby/permutation
parentdev-ruby/pg_array_parser: update HOMEPAGE (diff)
downloadgentoo-645f2d11a2374cd960c7e80cf871873341eb369a.tar.gz
gentoo-645f2d11a2374cd960c7e80cf871873341eb369a.tar.bz2
gentoo-645f2d11a2374cd960c7e80cf871873341eb369a.zip
dev-ruby/permutation: add ruby32, drop unused multilib
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/permutation')
-rw-r--r--dev-ruby/permutation/permutation-0.1.8-r3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/permutation/permutation-0.1.8-r3.ebuild b/dev-ruby/permutation/permutation-0.1.8-r3.ebuild
new file mode 100644
index 000000000000..0c8f09f10653
--- /dev/null
+++ b/dev-ruby/permutation/permutation-0.1.8-r3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library performing operations with permutations of sequences (strings, arrays)"
+HOMEPAGE="https://flori.github.io/permutation/"
+
+LICENSE="|| ( Ruby-BSD BSD-2 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test.rb || die
+}