summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-12-22 09:40:30 +0100
committerHans de Graaff <graaff@gentoo.org>2024-12-22 09:47:48 +0100
commitebafab80d04512b615c4638edddb5db539118016 (patch)
treee184e736cdfb8c6e1429dc3f93d72259566c57b0 /dev-ruby/puppet_forge/puppet_forge-6.0.0.ebuild
parentdev-ruby/rubygems: add patch (diff)
downloadgentoo-ebafab80d04512b615c4638edddb5db539118016.tar.gz
gentoo-ebafab80d04512b615c4638edddb5db539118016.tar.bz2
gentoo-ebafab80d04512b615c4638edddb5db539118016.zip
dev-ruby/puppet_forge: add 6.0.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/puppet_forge/puppet_forge-6.0.0.ebuild')
-rw-r--r--dev-ruby/puppet_forge/puppet_forge-6.0.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/puppet_forge/puppet_forge-6.0.0.ebuild b/dev-ruby/puppet_forge/puppet_forge-6.0.0.ebuild
new file mode 100644
index 000000000000..8219a4a1c0be
--- /dev/null
+++ b/dev-ruby/puppet_forge/puppet_forge-6.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tools to access Forge API information on Modules, Users, and Releases"
+HOMEPAGE="https://github.com/puppetlabs/forge-ruby"
+
+LICENSE="Apache-2.0"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+
+PATCHES=( "${FILESDIR}/${PN}-5.0.1-typhoeus.patch" )
+
+ruby_add_rdepend "
+ dev-ruby/faraday:2
+ >=dev-ruby/faraday-follow_redirects-0.3.0:0.3
+ >=dev-ruby/minitar-1.0.2:1
+ =dev-ruby/semantic_puppet-1*
+"
+
+all_ruby_prepare() {
+ # Avoid integration and user specs since they all require network access
+ rm -rf spec/integration spec/unit/forge/v3/user_spec.rb || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}