summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-09-09 07:36:01 +0200
committerHans de Graaff <graaff@gentoo.org>2023-09-09 07:38:52 +0200
commitac3808150a9823d9c89d060cfddb36c6363ed7cb (patch)
tree96ecb9b2541b5d3ac88722b04d67f91f9af6f954 /dev-ruby/puppet_forge
parentdev-ruby/faraday-follow_redirects: new package, add 0.3.0 (diff)
downloadgentoo-ac3808150a9823d9c89d060cfddb36c6363ed7cb.tar.gz
gentoo-ac3808150a9823d9c89d060cfddb36c6363ed7cb.tar.bz2
gentoo-ac3808150a9823d9c89d060cfddb36c6363ed7cb.zip
dev-ruby/puppet_forge: add 4.1.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/puppet_forge')
-rw-r--r--dev-ruby/puppet_forge/Manifest1
-rw-r--r--dev-ruby/puppet_forge/puppet_forge-4.1.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/puppet_forge/Manifest b/dev-ruby/puppet_forge/Manifest
index 775972368a8d..173c91849da0 100644
--- a/dev-ruby/puppet_forge/Manifest
+++ b/dev-ruby/puppet_forge/Manifest
@@ -1 +1,2 @@
DIST puppet_forge-3.2.0.gem 771072 BLAKE2B dd304297aa65dc0f36f837e27abf255a0474fc2216fa72ac3203febeb4085024f4d155e93a91646d1e7828fe67a5a421b2c75bb638deb846c5d337dfe11eafc9 SHA512 dfa82d96f44fb8247f39155c942bf20aec6a4a2833959c877ec98b150553076dd72112b6d1230fa7ae1acef7f648017a8446c3e952680f8d4a6411d2fc8055dc
+DIST puppet_forge-4.1.0.gem 772096 BLAKE2B 2d6f0af8baa067f79eb113f0de9596c562cdda678587fdd1cb14960535ded5fdbafb2b5ff0ebbd6ae676fb10d766f949b599b43c9b04dac55fc28b8163ef1383 SHA512 f752069d8b1998b3d27745abe3e6ad87a24ef614a68b52af2235a0587f98c69d8e39d2637640431f64d5c91ce468e3a2e2452b6ce8fa91d83b00c20ad047ae33
diff --git a/dev-ruby/puppet_forge/puppet_forge-4.1.0.ebuild b/dev-ruby/puppet_forge/puppet_forge-4.1.0.ebuild
new file mode 100644
index 000000000000..ff6f1063b086
--- /dev/null
+++ b/dev-ruby/puppet_forge/puppet_forge-4.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tools to access Forge API information on Modules, Users, and Releases"
+HOMEPAGE="https://github.com/puppetlabs/forge-ruby"
+
+LICENSE="Apache-2.0"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/faraday:2
+ >=dev-ruby/faraday-follow_redirects-0.3.0:0.3
+ dev-ruby/minitar
+ =dev-ruby/semantic_puppet-1*
+"
+
+all_ruby_prepare() {
+ # Avoid integration and user specs since they all require network access
+ rm -rf spec/integration spec/unit/forge/v3/user_spec.rb || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid specs that are broken when typhoeus is installed
+ rm -f spec/unit/forge/connection_spec.rb spec/unit/forge/v3/{base,release}_spec.rb || die
+}