summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2024-02-29 09:22:45 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2024-02-29 09:22:45 -0600
commiteca2adde9c981f7d2a406284c73a88aeb468096b (patch)
tree09fe51b499b79bacc9e548cafe6073f630ab6f72 /dev-ruby/puppetdb-termini
parentxfce-extra/xfce4-clipman-plugin: Bump to 1.6.6 (diff)
downloadgentoo-eca2adde9c981f7d2a406284c73a88aeb468096b.tar.gz
gentoo-eca2adde9c981f7d2a406284c73a88aeb468096b.tar.bz2
gentoo-eca2adde9c981f7d2a406284c73a88aeb468096b.zip
dev-ruby/puppetdb-termini: add 8.4.1
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/puppetdb-termini')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-8.4.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index 1c305a42f651..53fdf35a5ccc 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,2 +1,3 @@
DIST puppetdb-termini_7.13.0-1bullseye_all.deb 22548 BLAKE2B 535a3f846a7a10dcfaec4447ae852c6c4d870a573169f84e31f61c361164caea989f911df2d18e183c391dd0130a10b9422057eecaab304bebbb022f78e22a21 SHA512 3c8e440bfc55579d0c9a03ecae516d4cef49512ad9fdd6fceef37618c163ecac6d77a2b17b6cbb7131ceb3787904486bb78eef84a36a5f76672918db6d30db86
DIST puppetdb-termini_8.2.0-1focal_all.deb 21850 BLAKE2B 3f2d35a24c3884fdc985cd22e2c27d159dbea80272f5d1510634fc3b93079fd33e2b4f19963e2e122eb25829aa118ac13a84d6838c73ccb54305afc7876f8fc6 SHA512 ebf05f85d4bd455498a40b0210a6fc0cbfed4d0991d5a3d5780eb1b99a2f93f64407d6465d010c53ff55a0a3fcfab6f411c851d95a9e028945634644baef5163
+DIST puppetdb-termini_8.4.1-1focal_all.deb 21900 BLAKE2B 9d17deaaa0bc27aafdd20cc91aff9d7b9fac92fe6c7c536d6f606eedee5e30870325cd50e3f26e29c70865d7d0c9e5f6774179d6a9c10e84c7f08886837a5f91 SHA512 9f261efc3f6140cc8fc637fd7c9ee69c64bf06591581dada8b2aa95d25621b1165673786f8ee55d669e134fcf3676557adf5cbcad30c4e8a1447dd111dc486e4
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-8.4.1.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-8.4.1.ebuild
new file mode 100644
index 000000000000..c55da78154ac
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-8.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby31 ruby32"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="https://puppet.com/docs/puppetdb/latest/index.html"
+SRC_URI="http://apt.puppetlabs.com/pool/focal/puppet8/${PN:0:1}/${PN}/${PN}_${PV}-1focal_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="amd64 ~arm64 ~ppc x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}