summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-29 01:59:14 +0100
committerSam James <sam@gentoo.org>2023-03-29 13:55:27 +0100
commit28d65643bc1c1c9882c4f9ea0122a2d3bed7ecbf (patch)
treea971571687575612f8367015592a047d14528f75 /dev-ruby/sshkit
parentdev-ruby/airbrussh: drop 1.4.0-r1 (diff)
downloadgentoo-28d65643bc1c1c9882c4f9ea0122a2d3bed7ecbf.tar.gz
gentoo-28d65643bc1c1c9882c4f9ea0122a2d3bed7ecbf.tar.bz2
gentoo-28d65643bc1c1c9882c4f9ea0122a2d3bed7ecbf.zip
dev-ruby/sshkit: drop 1.21.2, 1.21.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/sshkit')
-rw-r--r--dev-ruby/sshkit/Manifest2
-rw-r--r--dev-ruby/sshkit/sshkit-1.21.2.ebuild43
-rw-r--r--dev-ruby/sshkit/sshkit-1.21.3.ebuild43
3 files changed, 0 insertions, 88 deletions
diff --git a/dev-ruby/sshkit/Manifest b/dev-ruby/sshkit/Manifest
index 6de81b7dfc82..22164caa71fe 100644
--- a/dev-ruby/sshkit/Manifest
+++ b/dev-ruby/sshkit/Manifest
@@ -1,3 +1 @@
-DIST sshkit-1.21.2.gem 144896 BLAKE2B ea72b1d0df7252f9c4ffe010721a957b5a86cc43697acf4dfd065a74cca5317deeb15692449d573a2e5590ef3a23ee666196b7b661d6986a2f270d16e2dc8d89 SHA512 37515726b67ae0e2ac9dff42cf7b71a32832ebe144aa192332780e4d9aead1a9e4c3cf7f6f0b994804175a5befd896b32908a82ba2e4f4a1d4e4b0f5bf01c3b3
-DIST sshkit-1.21.3.gem 144896 BLAKE2B 14cf7338187238f720cf8bf39664ba827700c1c47469cbd9e2f154a2b7bc91b4d8d14ec15d76db88fba1d23a936b112f0f2a33f2e15978a85816cd04274aea89 SHA512 ede63fd798db6e49fb2a1e9379699bd3e5de27f6b83640506a848f179fd83efed410357c899e97a41b1ab7e3baf47d88f87dcecf2bbcdf7475bea0d35817a9cc
DIST sshkit-1.21.4.gem 144896 BLAKE2B a4f7cd2342810422c6dd680370c741136bbe1cc59656333bb8a82ac2edd6eb0e3d5482cf671a3ffdcc38cd2f2a97140623728e213e8fd3098b223b9e601e6ea1 SHA512 c3a56b7dd80334b87d512054e98e8a72d93b036a4fb0adc34fad259c5b851de6a3c69549d1472442a3b822d371e80115849aa767dd7fda215fd0f626a7138173
diff --git a/dev-ruby/sshkit/sshkit-1.21.2.ebuild b/dev-ruby/sshkit/sshkit-1.21.2.ebuild
deleted file mode 100644
index ab2109f97a2d..000000000000
--- a/dev-ruby/sshkit/sshkit-1.21.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby27 ruby30"
-
-# There are functional tests that require vagrant boxes to be set up.
-RUBY_FAKEGEM_TASK_TEST="test:units"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="SSHKit makes it easy to write structured, testable SSH commands in Ruby"
-HOMEPAGE="https://github.com/capistrano/sshkit"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/net-ssh-2.8.0:*
- >=dev-ruby/net-scp-1.1.2
-"
-
-ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/mocha <dev-ruby/net-ssh-7 )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/I s:^:#:' Rakefile test/helper.rb || die
- sed -e '/\(turn\|unindent\|reporters\)/I s:^:#:' \
- -e '1irequire "set"; require "pathname"' \
- -e '1igem "net-ssh", "<7"' \
- -i test/helper.rb || die
-
- # Fix assumption about parent directory name
- sed -i -e '/assert_match/ s/sshkit/sshkit.*/' test/unit/test_deprecation_logger.rb || die
-}
-
-each_ruby_test() {
- # Run tests directly to avoid dependencies in the Rakefile
- ${RUBY} -Ilib:test:. -e "Dir['test/unit/**/test*.rb'].each{|f| require f}" || die
-}
diff --git a/dev-ruby/sshkit/sshkit-1.21.3.ebuild b/dev-ruby/sshkit/sshkit-1.21.3.ebuild
deleted file mode 100644
index 0c59a5fd2f75..000000000000
--- a/dev-ruby/sshkit/sshkit-1.21.3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby27 ruby30"
-
-# There are functional tests that require vagrant boxes to be set up.
-RUBY_FAKEGEM_TASK_TEST="test:units"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="SSHKit makes it easy to write structured, testable SSH commands in Ruby"
-HOMEPAGE="https://github.com/capistrano/sshkit"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/net-ssh-2.8.0:*
- >=dev-ruby/net-scp-1.1.2
-"
-
-ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/mocha <dev-ruby/net-ssh-7 )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/I s:^:#:' Rakefile test/helper.rb || die
- sed -e '/\(turn\|unindent\|reporters\)/I s:^:#:' \
- -e '1irequire "set"; require "pathname"' \
- -e '1igem "net-ssh", "<7"' \
- -i test/helper.rb || die
-
- # Fix assumption about parent directory name
- sed -i -e '/assert_match/ s/sshkit/sshkit.*/' test/unit/test_deprecation_logger.rb || die
-}
-
-each_ruby_test() {
- # Run tests directly to avoid dependencies in the Rakefile
- ${RUBY} -Ilib:test:. -e "Dir['test/unit/**/test*.rb'].each{|f| require f}" || die
-}