summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-11-07 07:17:22 +0100
committerHans de Graaff <graaff@gentoo.org>2018-11-07 08:18:12 +0100
commitc445c88bc79f8a37ff59059ec51f156f2523776e (patch)
tree4f11ef901ffd068a1c364a854ebbc5ca54cbeb18 /dev-ruby/stringex/stringex-2.8.5.ebuild
parentdev-lang/gnat-gpl: stabilize and drop old (diff)
downloadgentoo-c445c88bc79f8a37ff59059ec51f156f2523776e.tar.gz
gentoo-c445c88bc79f8a37ff59059ec51f156f2523776e.tar.bz2
gentoo-c445c88bc79f8a37ff59059ec51f156f2523776e.zip
dev-ruby/stringex: add 2.8.5
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/stringex/stringex-2.8.5.ebuild')
-rw-r--r--dev-ruby/stringex/stringex-2.8.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/stringex/stringex-2.8.5.ebuild b/dev-ruby/stringex/stringex-2.8.5.ebuild
new file mode 100644
index 000000000000..30df68532aba
--- /dev/null
+++ b/dev-ruby/stringex/stringex-2.8.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Extensions for Ruby's String class"
+HOMEPAGE="https://github.com/rsl/stringex"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64"
+IUSE="test"
+
+# we could rely on activerecord[sqlite3], but since we do not remove the
+# sqlite3 adapter from activerecord when building -sqlite3, it's easier
+# to just add another dependency, so the user doesn't have to change the
+# USE flags at all.
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/i18n-0.7.0:0.7
+ dev-ruby/redcloth
+ dev-ruby/test-unit:2
+ >=dev-ruby/activerecord-3
+ dev-ruby/sqlite3 )"
+
+all_ruby_prepare() {
+ sed -i -e '1agem "i18n", "~>0.7.0"' test/test_helper.rb || die
+}