summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-09-08 08:14:48 +0200
committerHans de Graaff <graaff@gentoo.org>2024-09-08 08:44:34 +0200
commitd8cc96691e861dc3c0ee81c16b8420bb18775cf4 (patch)
treec640754e59e5db68ca8bbc76fb5abadf16df1d8a /dev-ruby/vcr
parentdev-ruby/rspec-expectations: add 3.13.3 (diff)
downloadgentoo-d8cc96691e861dc3c0ee81c16b8420bb18775cf4.tar.gz
gentoo-d8cc96691e861dc3c0ee81c16b8420bb18775cf4.tar.bz2
gentoo-d8cc96691e861dc3c0ee81c16b8420bb18775cf4.zip
dev-ruby/vcr: add 6.3.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/vcr')
-rw-r--r--dev-ruby/vcr/Manifest1
-rw-r--r--dev-ruby/vcr/vcr-6.3.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/vcr/Manifest b/dev-ruby/vcr/Manifest
index cb91f378343a..e72638423072 100644
--- a/dev-ruby/vcr/Manifest
+++ b/dev-ruby/vcr/Manifest
@@ -1 +1,2 @@
DIST vcr-6.2.0.tar.gz 154715 BLAKE2B 5d6054c81106a1498c91a578347d1c092908d98d79e58303b5718620ef699705d33bfa1ea4ea8fd37653298cc18812a84d8125b79ad5fab746277ecf27725afc SHA512 516e7a8acb06872e111f20e07f3b95713a8e2cf7b5f6939ae1b643cafa8e87488a98ee5d0cf1ec0e150c128e19241c2e6d0c4ab8e811584d9f8ed05e8f93a691
+DIST vcr-6.3.1.tar.gz 155338 BLAKE2B 2ce48ae9abcec56a5e55f03f53dcceff9dabfa119ee8dfd2aa7a483b048cb8ebe60c6a39436ac639e1a94b11119369ba43b4531d99538f854e3a2f213def56c0 SHA512 903132c5686c086069875209ebdf4bc1251725567dbeab6a62b35a6091f2231446c26455ba5409d2ad3f67b04695cf8f48abf2496df0b90d3462d8a47aeba890
diff --git a/dev-ruby/vcr/vcr-6.3.1.ebuild b/dev-ruby/vcr/vcr-6.3.1.ebuild
new file mode 100644
index 000000000000..0d8d68d0e4b6
--- /dev/null
+++ b/dev-ruby/vcr/vcr-6.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md CONTRIBUTING.md README.md Upgrade.md"
+
+RUBY_FAKEGEM_GEMSPEC="vcr.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Records your test suite's HTTP interactions and replay them during test runs"
+HOMEPAGE="https://github.com/vcr/vcr/"
+SRC_URI="https://github.com/vcr/vcr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86"
+IUSE="json test"
+
+# Tests require all supported HTTP libraries to be present, and it is
+# not possible to avoid some of them without very extensive patches.
+RESTRICT="test"
+
+ruby_add_rdepend "
+ dev-ruby/base64
+ json? ( dev-ruby/json )
+"