summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-08-13 08:43:42 +0200
committerHans de Graaff <graaff@gentoo.org>2021-08-13 08:56:32 +0200
commitd2c6ace8d91b84de0b6aa391a6d9520e7823904f (patch)
tree9389c6c839f047b8d96dcbb0927b92f16a50f1a2 /dev-ruby/will_paginate/will_paginate-3.3.1.ebuild
parentmedia-video/kino: ppc stable wrt bug #783720 (diff)
downloadgentoo-d2c6ace8d91b84de0b6aa391a6d9520e7823904f.tar.gz
gentoo-d2c6ace8d91b84de0b6aa391a6d9520e7823904f.tar.bz2
gentoo-d2c6ace8d91b84de0b6aa391a6d9520e7823904f.zip
dev-ruby/will_paginate: add 3.3.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/will_paginate/will_paginate-3.3.1.ebuild')
-rw-r--r--dev-ruby/will_paginate/will_paginate-3.3.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/will_paginate/will_paginate-3.3.1.ebuild b/dev-ruby/will_paginate/will_paginate-3.3.1.ebuild
new file mode 100644
index 000000000000..ce6a5ea33efd
--- /dev/null
+++ b/dev-ruby/will_paginate/will_paginate-3.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Most awesome pagination solution for Ruby"
+HOMEPAGE="https://github.com/mislav/will_paginate/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ # Remove tests for unpackaged ORMs
+ rm -f spec/finders/{sequel,mongoid,data_mapper}* || die
+}
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rails
+ dev-ruby/sqlite3
+ dev-ruby/mocha
+ )"