summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-07-04 13:54:17 +0200
committerHans de Graaff <graaff@gentoo.org>2023-07-05 06:40:31 +0200
commit3df8f6e2f3e036d58457ee86827abf8df8adc00a (patch)
tree27ef381b2540b309dc56712f585c9c1543a1a677 /dev-ruby
parentdev-ruby/hiera: drop 3.10.0, 3.11.0 (diff)
downloadgentoo-3df8f6e2f3e036d58457ee86827abf8df8adc00a.tar.gz
gentoo-3df8f6e2f3e036d58457ee86827abf8df8adc00a.tar.bz2
gentoo-3df8f6e2f3e036d58457ee86827abf8df8adc00a.zip
dev-ruby/heredoc_unindent: update EAPI 7 -> 8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r2.ebuild b/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r2.ebuild
new file mode 100644
index 000000000000..e4818a90970d
--- /dev/null
+++ b/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
+DESCRIPTION="Removes leading whitespace from Ruby heredocs"
+HOMEPAGE="https://github.com/adrianomitre/heredoc_unindent"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '1igem "test-unit"' test/test_heredoc_unindent.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}