summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-03 16:59:43 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-03 17:05:38 +0100
commit4057b1d7add942eb4da35d7b4ff2695990068bac (patch)
tree0a51807cc4c232577fc0e456a7fff5e5bf14851b /dev-scheme/racket/racket-7.3-r1.ebuild
parentnet-libs/ldns: Stabilize 1.8.0-r1 ppc64, #827968 (diff)
downloadgentoo-4057b1d7add942eb4da35d7b4ff2695990068bac.tar.gz
gentoo-4057b1d7add942eb4da35d7b4ff2695990068bac.tar.bz2
gentoo-4057b1d7add942eb4da35d7b4ff2695990068bac.zip
dev-scheme/racket: drop old
remove vulnerable versions lesser than 8.2 Bug: https://bugs.gentoo.org/803116 Closes: https://bugs.gentoo.org/711098 Closes: https://bugs.gentoo.org/715324 Closes: https://bugs.gentoo.org/749729 Closes: https://bugs.gentoo.org/749735 Closes: https://bugs.gentoo.org/755008 Closes: https://bugs.gentoo.org/779466 Closes: https://bugs.gentoo.org/814899 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-scheme/racket/racket-7.3-r1.ebuild')
-rw-r--r--dev-scheme/racket/racket-7.3-r1.ebuild94
1 files changed, 0 insertions, 94 deletions
diff --git a/dev-scheme/racket/racket-7.3-r1.ebuild b/dev-scheme/racket/racket-7.3-r1.ebuild
deleted file mode 100644
index 367977769dc9..000000000000
--- a/dev-scheme/racket/racket-7.3-r1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit pax-utils
-
-DESCRIPTION="General purpose, multi-paradigm Lisp-Scheme programming language"
-HOMEPAGE="https://racket-lang.org/"
-SRC_URI="minimal? ( https://download.racket-lang.org/installers/${PV}/${PN}-minimal-${PV}-src-builtpkgs.tgz ) !minimal? ( https://download.racket-lang.org/installers/${PV}/${P}-src-builtpkgs.tgz )"
-LICENSE="GPL-3+ LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE="doc +futures +jit minimal +places +readline +threads +X"
-REQUIRED_USE="futures? ( jit )"
-
-RDEPEND="dev-db/sqlite:3
- media-libs/libpng:0
- x11-libs/cairo[X?]
- x11-libs/pango[X?]
- dev-libs/libffi:=
- virtual/jpeg:0
- readline? ( dev-libs/libedit )
- X? ( x11-libs/gtk+[X?] )"
-RDEPEND="${RDEPEND} !dev-tex/slatex"
-
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${P}/src"
-
-src_prepare() {
- default
- rm -r foreign/libffi || die 'failed to remove bundled libffi'
-}
-
-src_configure() {
- # According to vapier, we should use the bundled libtool
- # such that we don't preclude cross-compile. Thus don't use
- # --enable-lt=/usr/bin/libtool
- econf \
- --enable-shared \
- --enable-float \
- --enable-libffi \
- --enable-foreign \
- --disable-libs \
- --disable-strip \
- $(use_enable X gracket) \
- $(use_enable doc docs) \
- $(use_enable jit) \
- $(use_enable places) \
- $(use_enable futures) \
- $(use_enable threads pthread)
-}
-
-src_compile() {
- if use jit; then
- # When the JIT is enabled, a few binaries need to be pax-marked
- # on hardened systems (bug 613634). The trick is to pax-mark
- # them before they're used later in the build system. The
- # following order for racketcgc and racket3m was determined by
- # digging through the Makefile in src/racket to find out which
- # targets would build those binaries but not use them.
- pushd racket
- emake cgc-core
- pax-mark m .libs/racketcgc
- pushd gc2
- emake all
- popd
- pax-mark m .libs/racket3m
- popd
- fi
-
- default
-}
-
-src_install() {
- default
-
- if use jit; then
- # The final binaries need to be pax-marked, too, if you want to
- # actually use them. The src_compile marking get lost somewhere
- # in the install process.
- for f in mred mzscheme racket; do
- pax-mark m "${D}/usr/bin/${f}"
- done
-
- use X && pax-mark m "${D}/usr/$(get_libdir)/racket/gracket"
- fi
- # raco needs decompressed files for packages doc installation bug 662424
- if use doc; then
- docompress -x /usr/share/doc/${PF}
- fi
- find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
-}