summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-10-27 22:15:46 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-10-27 22:15:46 +0200
commitfc8e802cd093a18b6822a21ba4aaf8f6e382e805 (patch)
tree9c64de102a4a98313cef7d2eceb04aea24afc937 /dev-tcltk/tcl3d
parentnet-im/mattermost-desktop-bin: 5.0.1 bump (diff)
downloadgentoo-fc8e802cd093a18b6822a21ba4aaf8f6e382e805.tar.gz
gentoo-fc8e802cd093a18b6822a21ba4aaf8f6e382e805.tar.bz2
gentoo-fc8e802cd093a18b6822a21ba4aaf8f6e382e805.zip
dev-tcltk/tcl3d: EAPI 7 and hopefully fix for #816825
Closes: https://bugs.gentoo.org/816825 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk/tcl3d')
-rw-r--r--dev-tcltk/tcl3d/tcl3d-0.5.0.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/dev-tcltk/tcl3d/tcl3d-0.5.0.ebuild b/dev-tcltk/tcl3d/tcl3d-0.5.0.ebuild
index f24710e3f1e8..7a07697e35ae 100644
--- a/dev-tcltk/tcl3d/tcl3d-0.5.0.ebuild
+++ b/dev-tcltk/tcl3d/tcl3d-0.5.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic toolchain-funcs
@@ -31,6 +31,15 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PN}"
PATCHES=( "${FILESDIR}/${P}-include-tk-dir-and-permissive.patch" )
+src_prepare() {
+ sed -i \
+ -e '/\..$(DSEP)pkgIndex.tcl/d' \
+ tcl3d*/Makefile \
+ || die
+
+ default
+}
+
src_configure() {
local _TCL_V=( $(echo 'puts [info tclversion]' | tclsh | tr '.' ' ') )
local _TCL_FV="${_TCL_V[0]}.${_TCL_V[1]}"
@@ -74,4 +83,6 @@ src_compile() {
src_install() {
emake INSTDIR="${D}/usr" DESTDIR="${D}" INSTLIB="${D}/usr/$(get_libdir)" install
+ insinto /usr/$(get_libdir)/${PN}${PV}
+ doins pkgIndex.tcl
}