summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/tclperl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/tclperl')
-rw-r--r--dev-tcltk/tclperl/Manifest1
-rw-r--r--dev-tcltk/tclperl/metadata.xml5
-rw-r--r--dev-tcltk/tclperl/tclperl-3.2-r1.ebuild42
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-tcltk/tclperl/Manifest b/dev-tcltk/tclperl/Manifest
new file mode 100644
index 000000000000..42927aecfd61
--- /dev/null
+++ b/dev-tcltk/tclperl/Manifest
@@ -0,0 +1 @@
+DIST tclperl-3.2.tar.bz2 11765 SHA256 3643915a2f3d51da4d6296d0b57d796163ba0358f65bc97da6c0ef5cccb26173 SHA512 aed6fb4b0275cf75e6024336e81e3cd1502d82ae697e79b6142d2f9b3cfb0891541cc585fa83d6219632f11d6eda43b141d009caf5fe7433b2b2ca92aa875c00 WHIRLPOOL a64d8b043f208cd4a76424920c3510baed0ceecb9b5308463e6d6739df4d89cb7b4bde13b69db0c65e9da653a41fa64ca78986eeabf9631720e18e8fd6571862
diff --git a/dev-tcltk/tclperl/metadata.xml b/dev-tcltk/tclperl/metadata.xml
new file mode 100644
index 000000000000..70ac40499556
--- /dev/null
+++ b/dev-tcltk/tclperl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tcltk</herd>
+</pkgmetadata>
diff --git a/dev-tcltk/tclperl/tclperl-3.2-r1.ebuild b/dev-tcltk/tclperl/tclperl-3.2-r1.ebuild
new file mode 100644
index 000000000000..c56754a6150d
--- /dev/null
+++ b/dev-tcltk/tclperl/tclperl-3.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Perl package for Tcl"
+HOMEPAGE="http://jfontain.free.fr/tclperl.htm"
+SRC_URI="http://jfontain.free.fr/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/tcl-8.3.3:0
+ >=dev-lang/perl-5.6.0"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ append-flags -fPIC
+
+ # ./build.sh
+ perl Makefile.PL || die
+ emake OPTIMIZE="${CFLAGS}" Tcl.o
+
+ $(tc-getCC) -shared ${LDFLAGS} ${CFLAGS} -o tclperl.so.${PV} -DUSE_TCL_STUBS \
+ tclperl.c tclthread.c `perl -MExtUtils::Embed -e ccopts -e ldopts` \
+ /usr/$(get_libdir)/libtclstub`echo 'puts $tcl_version' | tclsh`.a Tcl.o || die
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/${P}
+ doexe tclperl.so.${PV}
+ doexe pkgIndex.tcl
+
+ dodoc CHANGES README
+ dohtml tclperl.htm
+}