summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-02-29 19:37:28 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-02-29 19:38:28 +0100
commit6f24a7abe601fc74f76210a8169bd5d758091cfe (patch)
tree76f22213c92c3087bac4522018005ce6a9d57c6d /dev-tcltk
parentnet-analyzer/greenbone-feed-sync: add missing pontos test dependency (diff)
downloadgentoo-6f24a7abe601fc74f76210a8169bd5d758091cfe.tar.gz
gentoo-6f24a7abe601fc74f76210a8169bd5d758091cfe.tar.bz2
gentoo-6f24a7abe601fc74f76210a8169bd5d758091cfe.zip
dev-tcltk/itk: fix install script
Closes: https://bugs.gentoo.org/925741 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/itk/files/itk-4.2.3-install.patch11
-rw-r--r--dev-tcltk/itk/itk-4.2.3.ebuild6
2 files changed, 16 insertions, 1 deletions
diff --git a/dev-tcltk/itk/files/itk-4.2.3-install.patch b/dev-tcltk/itk/files/itk-4.2.3-install.patch
new file mode 100644
index 000000000000..1adc7574ba41
--- /dev/null
+++ b/dev-tcltk/itk/files/itk-4.2.3-install.patch
@@ -0,0 +1,11 @@
+--- a/configure 2024-02-29 19:28:27.192049469 +0100
++++ b/configure 2024-02-29 19:28:41.507876154 +0100
+@@ -2627,7 +2627,7 @@
+
+ # Configure the installer.
+
+- INSTALL='$(SHELL) $(srcdir)/tclconfig/install-sh -c'
++ INSTALL='$(SHELL) install -c'
+ INSTALL_DATA_DIR='${INSTALL} -d -m 755'
+ INSTALL_DATA='${INSTALL} -m 644'
+ INSTALL_PROGRAM='${INSTALL} -m 755'
diff --git a/dev-tcltk/itk/itk-4.2.3.ebuild b/dev-tcltk/itk/itk-4.2.3.ebuild
index 493cb8bd0beb..cd62e1a40f6f 100644
--- a/dev-tcltk/itk/itk-4.2.3.ebuild
+++ b/dev-tcltk/itk/itk-4.2.3.ebuild
@@ -27,6 +27,10 @@ QA_CONFIG_IMPL_DECL_SKIP=(
stat64 # used to test for Large File Support
)
+PATCHES=( "${FILESDIR}"/${P}-install.patch )
+
+UNINSTALL_IGNORE='/usr/lib.*/itk.*/library'
+
src_prepare() {
sed 's:-pipe::g' -i configure || die
default
@@ -64,5 +68,5 @@ src_install() {
LDPATH="${EPREFIX}/usr/$(get_libdir)/${PN}${MY_PV}/"
EOF
doenvd "${T}"/34${PN}
- dosym . /usr/$(get_libdir)/${PN}${MY_PV}/library
+ dosym . /usr/$(get_libdir)/${PN}${PV}/library
}