summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2021-07-01 10:57:56 +0200
committerFlorian Schmaus <flow@gentoo.org>2021-07-01 11:01:37 +0200
commit50daee8ac8faf1c64330064c88d11fa8a781f3bd (patch)
tree44c2659c62e04071d5f6180c1a9d1e67fad7d269 /dev-tex/rubber/rubber-1.5.1-r1.ebuild
parentdev-python/urllib3: Stabilize 1.26.5 ALLARCHES, #799413 (diff)
downloadgentoo-50daee8ac8faf1c64330064c88d11fa8a781f3bd.tar.gz
gentoo-50daee8ac8faf1c64330064c88d11fa8a781f3bd.tar.bz2
gentoo-50daee8ac8faf1c64330064c88d11fa8a781f3bd.zip
dev-tex/rubber: set VARTEXFONTS="${T}"/fonts
Closes: https://bugs.gentoo.org/727996 Signed-off-by: Florian Schmaus <flow@gentoo.org> Suggested-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'dev-tex/rubber/rubber-1.5.1-r1.ebuild')
-rw-r--r--dev-tex/rubber/rubber-1.5.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-tex/rubber/rubber-1.5.1-r1.ebuild b/dev-tex/rubber/rubber-1.5.1-r1.ebuild
new file mode 100644
index 000000000000..493309ed1988
--- /dev/null
+++ b/dev-tex/rubber/rubber-1.5.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A LaTeX wrapper for automatically building documents"
+HOMEPAGE="https://launchpad.net/rubber/"
+SRC_URI="https://launchpad.net/rubber/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="virtual/latex-base"
+BDEPEND="${RDEPEND}
+ virtual/texi2dvi"
+
+pkg_setup() {
+ # https://bugs.gentoo.org/727996
+ export VARTEXFONTS="${T}"/fonts
+}
+
+python_install() {
+ distutils-r1_python_install \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --infodir="${EPREFIX}"/usr/share/info \
+ --mandir="${EPREFIX}"/usr/share/man
+}