summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2021-03-29 17:35:00 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-04-10 10:44:39 +0300
commitf493874fb34c5817081a0545f61be16165bfca50 (patch)
treebcb2242be1101553a451e8075a73ef3737bc09d0 /dev-util/apitrace
parentdev-vcs/git-lfs: Remove the old version (diff)
downloadgentoo-f493874fb34c5817081a0545f61be16165bfca50.tar.gz
gentoo-f493874fb34c5817081a0545f61be16165bfca50.tar.bz2
gentoo-f493874fb34c5817081a0545f61be16165bfca50.zip
dev-util/apitrace: Put libX11/mesa[X] behind USE=X
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/20179 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/apitrace')
-rw-r--r--dev-util/apitrace/apitrace-9.0-r1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-util/apitrace/apitrace-9.0-r1.ebuild b/dev-util/apitrace/apitrace-9.0-r1.ebuild
index dde14319289d..4834bd7b743b 100644
--- a/dev-util/apitrace/apitrace-9.0-r1.ebuild
+++ b/dev-util/apitrace/apitrace-9.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="qt5"
+IUSE="qt5 X"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -22,11 +22,11 @@ DEPEND="${PYTHON_DEPS}
app-arch/brotli:=[${MULTILIB_USEDEP}]
>=app-arch/snappy-1.1.1[${MULTILIB_USEDEP}]
media-libs/libpng:0=
- media-libs/mesa[egl,gles1,gles2,X(+),${MULTILIB_USEDEP}]
+ media-libs/mesa[egl,gles1,gles2,X?,${MULTILIB_USEDEP}]
>=media-libs/waffle-1.6.0-r1[egl,${MULTILIB_USEDEP}]
sys-libs/zlib[${MULTILIB_USEDEP}]
sys-process/procps:=[${MULTILIB_USEDEP}]
- x11-libs/libX11
+ X? ( x11-libs/libX11 )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5[-gles2-only]
@@ -55,6 +55,7 @@ src_configure() {
my_configure() {
local mycmakeargs=(
-DDOC_INSTALL_DIR="${EPREFIX}"/usr/share/doc/${PF}
+ -DENABLE_X11=$(usex X)
-DENABLE_EGL=ON
-DENABLE_CLI=ON
-DENABLE_GUI=$(multilib_native_usex qt5)
@@ -71,8 +72,8 @@ src_install() {
MULTILIB_CHOST_TOOLS=(
/usr/bin/apitrace$(get_exeext)
/usr/bin/eglretrace$(get_exeext)
- /usr/bin/glretrace$(get_exeext)
)
+ use X && MULTILIB_CHOST_TOOLS+=( /usr/bin/glretrace$(get_exeext) )
cmake-multilib_src_install
@@ -81,5 +82,5 @@ src_install() {
dosym glxtrace.so /usr/$(get_libdir)/${PN}/wrappers/libGL.so.1
dosym glxtrace.so /usr/$(get_libdir)/${PN}/wrappers/libGL.so.1.2
}
- multilib_foreach_abi make_libgl_symlinks
+ use X && multilib_foreach_abi make_libgl_symlinks
}