summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/buildbot-slave
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/buildbot-slave')
-rw-r--r--dev-util/buildbot-slave/Manifest2
-rw-r--r--dev-util/buildbot-slave/buildbot-slave-0.8.10.ebuild54
-rw-r--r--dev-util/buildbot-slave/buildbot-slave-0.8.12.ebuild54
-rw-r--r--dev-util/buildbot-slave/buildbot-slave-9999.ebuild67
-rw-r--r--dev-util/buildbot-slave/files/buildslave.confd9
-rw-r--r--dev-util/buildbot-slave/files/buildslave.initd48
-rw-r--r--dev-util/buildbot-slave/files/buildslave.service15
-rw-r--r--dev-util/buildbot-slave/metadata.xml11
8 files changed, 260 insertions, 0 deletions
diff --git a/dev-util/buildbot-slave/Manifest b/dev-util/buildbot-slave/Manifest
new file mode 100644
index 000000000000..6557b0dbdc86
--- /dev/null
+++ b/dev-util/buildbot-slave/Manifest
@@ -0,0 +1,2 @@
+DIST buildbot-slave-0.8.10.tar.gz 117593 SHA256 ef5634249407bf643b666976158a4e11c7aaa3db3658ff0fcd781f460867f626 SHA512 0b05f8b9d6e6c29291893c47707409bc50681d2631ed1825908050f30cff34bf422d7f574076ea9c6b36a16b37e2e79ed28c9e84e31b3270bf6ec3aee426def4 WHIRLPOOL 52806ebd2e2c54bf844fb4752ded7ea314fd68cba229ea09039e0b83b1cdd373e40528d779ce5b3a188028932f3d443986f006bfb5555eaf141569ba3949297e
+DIST buildbot-slave-0.8.12.tar.gz 118339 SHA256 905eab122dcfc9425d51f0ed0c7682e7f933e140a7203637aa12a84498bd7461 SHA512 74f7f9ffab946000a5d31ae28140698ca259ba5b75815ed839d51fa5d9f702e998b61a716b66aab7946b6143d329244f2403d9b98cbbfc70223b691dcb70f0bc WHIRLPOOL f0281c11520ff31291977fa67397c7398d8ecf7fe0e70a45521158e792862aa9bb6eb65591181a1a3d71913241768e65143a1b35d6316cb5f8b5bc5373d02979
diff --git a/dev-util/buildbot-slave/buildbot-slave-0.8.10.ebuild b/dev-util/buildbot-slave/buildbot-slave-0.8.10.ebuild
new file mode 100644
index 000000000000..4717aa5b64c8
--- /dev/null
+++ b/dev-util/buildbot-slave/buildbot-slave-0.8.10.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1 readme.gentoo systemd user
+
+DESCRIPTION="BuildBot Slave Daemon"
+HOMEPAGE="http://trac.buildbot.net/ http://code.google.com/p/buildbot/ http://pypi.python.org/pypi/buildbot-slave"
+
+MY_PV="${PV/_p/p}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-interix ~amd64-linux"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewuser buildbot
+
+ DOC_CONTENTS="The \"buildbot\" user and the \"buildslave\" init script has been added
+ to support starting buildslave through Gentoo's init system. To use this,
+ set up your build slave following the documentation, make sure the
+ resulting directories are owned by the \"buildbot\" user and point
+ \"${ROOT}etc/conf.d/buildslave\" at the right location. The scripts can
+ run as a different user if desired. If you need to run more than one
+ build slave, just copy the scripts."
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman docs/buildslave.1
+
+ newconfd "${FILESDIR}/buildslave.confd" buildslave
+ newinitd "${FILESDIR}/buildslave.initd" buildslave
+ systemd_dounit "${FILESDIR}/buildslave.service"
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/dev-util/buildbot-slave/buildbot-slave-0.8.12.ebuild b/dev-util/buildbot-slave/buildbot-slave-0.8.12.ebuild
new file mode 100644
index 000000000000..4717aa5b64c8
--- /dev/null
+++ b/dev-util/buildbot-slave/buildbot-slave-0.8.12.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1 readme.gentoo systemd user
+
+DESCRIPTION="BuildBot Slave Daemon"
+HOMEPAGE="http://trac.buildbot.net/ http://code.google.com/p/buildbot/ http://pypi.python.org/pypi/buildbot-slave"
+
+MY_PV="${PV/_p/p}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-interix ~amd64-linux"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewuser buildbot
+
+ DOC_CONTENTS="The \"buildbot\" user and the \"buildslave\" init script has been added
+ to support starting buildslave through Gentoo's init system. To use this,
+ set up your build slave following the documentation, make sure the
+ resulting directories are owned by the \"buildbot\" user and point
+ \"${ROOT}etc/conf.d/buildslave\" at the right location. The scripts can
+ run as a different user if desired. If you need to run more than one
+ build slave, just copy the scripts."
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman docs/buildslave.1
+
+ newconfd "${FILESDIR}/buildslave.confd" buildslave
+ newinitd "${FILESDIR}/buildslave.initd" buildslave
+ systemd_dounit "${FILESDIR}/buildslave.service"
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/dev-util/buildbot-slave/buildbot-slave-9999.ebuild b/dev-util/buildbot-slave/buildbot-slave-9999.ebuild
new file mode 100644
index 000000000000..55063dbed836
--- /dev/null
+++ b/dev-util/buildbot-slave/buildbot-slave-9999.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+[[ ${PV} = 9999 ]] && inherit git-2
+inherit distutils-r1 readme.gentoo user
+
+DESCRIPTION="BuildBot Slave Daemon"
+HOMEPAGE="http://trac.buildbot.net/ http://code.google.com/p/buildbot/ http://pypi.python.org/pypi/buildbot-slave"
+
+MY_PV="${PV/_p/p}"
+MY_P="${PN}-${MY_PV}"
+[[ ${PV} = 9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+if [[ ${PV} == 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux"
+fi
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewuser buildbot
+
+ DOC_CONTENTS="The \"buildbot\" user and the \"buildslave\" init script has been added
+ to support starting buildslave through Gentoo's init system. To use this,
+ set up your build slave following the documentation, make sure the
+ resulting directories are owned by the \"buildbot\" user and point
+ \"${ROOT}etc/conf.d/buildslave\" at the right location. The scripts can
+ run as a different user if desired. If you need to run more than one
+ build slave, just copy the scripts."
+}
+
+src_compile() {
+ [[ ${PV} = 9999 ]] && cd slave/
+ distutils-r1_src_compile
+}
+
+src_install() {
+ [[ ${PV} = 9999 ]] && cd slave/
+ distutils-r1_src_install
+
+ doman docs/buildslave.1
+
+ newconfd "${FILESDIR}/buildslave.confd" buildslave
+ newinitd "${FILESDIR}/buildslave.initd" buildslave
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ [[ ${PV} = 9999 ]] && cd slave/
+ readme.gentoo_print_elog
+}
diff --git a/dev-util/buildbot-slave/files/buildslave.confd b/dev-util/buildbot-slave/files/buildslave.confd
new file mode 100644
index 000000000000..4ef42c4a7333
--- /dev/null
+++ b/dev-util/buildbot-slave/files/buildslave.confd
@@ -0,0 +1,9 @@
+# Path to the build slave's basedir.
+BASEDIR="/var/lib/buildslave"
+
+# User account for the buildslave.
+# The basedir should be owned by this user.
+USERNAME="buildbot"
+
+# Extra options passed to twistd.
+TWISTD_OPTS=""
diff --git a/dev-util/buildbot-slave/files/buildslave.initd b/dev-util/buildbot-slave/files/buildslave.initd
new file mode 100644
index 000000000000..17e22abdc7cb
--- /dev/null
+++ b/dev-util/buildbot-slave/files/buildslave.initd
@@ -0,0 +1,48 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ -z "${BASEDIR}" ]; then
+ eerror "BASEDIR not set"
+ return 1
+ fi
+ if [ -z "${USERNAME}" ]; then
+ eerror "USERNAME not set"
+ return 1
+ fi
+ if [ ! -d "${BASEDIR}" ]; then
+ eerror "${BASEDIR} is not a directory"
+ return 1
+ fi
+ if [ ! -e "${BASEDIR}/buildbot.tac" ]; then
+ eerror "${BASEDIR} does not contain buildbot.tac"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting buildslave in ${BASEDIR}"
+ # We set HOME here to make something valid show up in the env of child
+ # processes spawned by the buildslave.
+ start-stop-daemon --start -u "${USERNAME}" \
+ --pidfile "${BASEDIR}/buildslave.pid" \
+ --env HOME="${BASEDIR}" \
+ --exec /usr/bin/python -- /usr/bin/twistd \
+ --no_save \
+ --logfile="${BASEDIR}/twistd.log" \
+ --pidfile="${BASEDIR}/buildslave.pid" \
+ --python="${BASEDIR}/buildbot.tac"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping buildslave in ${BASEDIR}"
+ start-stop-daemon --stop --pidfile "${BASEDIR}/buildslave.pid"
+ eend $?
+}
diff --git a/dev-util/buildbot-slave/files/buildslave.service b/dev-util/buildbot-slave/files/buildslave.service
new file mode 100644
index 000000000000..5c8e483fe83a
--- /dev/null
+++ b/dev-util/buildbot-slave/files/buildslave.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=buildbot slave instances
+After=local-fs.target network.target
+
+[Service]
+Type=forking
+User=buildbot
+WorkingDirectory=/var/lib/buildslave
+# The following assume there is a 'slave' directory
+# in $WorkingDirectory with the slave configuration files
+ExecStart=/usr/bin/buildslave start slave
+ExecStop=/usr/bin/buildslave stop slave
+
+[Install]
+WantedBy=multi-user.target
diff --git a/dev-util/buildbot-slave/metadata.xml b/dev-util/buildbot-slave/metadata.xml
new file mode 100644
index 000000000000..8249217c63d1
--- /dev/null
+++ b/dev-util/buildbot-slave/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">buildbot-slave</remote-id>
+ </upstream>
+</pkgmetadata>