summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-12-21 10:05:21 +0000
committerArthur Zamarin <arthurzam@gentoo.org>2024-12-21 10:12:08 +0000
commit4bfa1e41a67069fe5c2849e8ba00736bb4c2ded6 (patch)
treed85bc23dcfe96ca11b4a11728ca95564df6bc719 /dev-util/codespell
parentapp-editors/vscodium: drop 1.95.2.24313, 1.95.3.24321-r1 (diff)
downloadgentoo-4bfa1e41a67069fe5c2849e8ba00736bb4c2ded6.tar.gz
gentoo-4bfa1e41a67069fe5c2849e8ba00736bb4c2ded6.tar.bz2
gentoo-4bfa1e41a67069fe5c2849e8ba00736bb4c2ded6.zip
dev-util/codespell: add 2.3.0
Closes: https://bugs.gentoo.org/946722 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-util/codespell')
-rw-r--r--dev-util/codespell/Manifest1
-rw-r--r--dev-util/codespell/codespell-2.3.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/codespell/Manifest b/dev-util/codespell/Manifest
index 2e077fb9b013..fcaf56fb5f4c 100644
--- a/dev-util/codespell/Manifest
+++ b/dev-util/codespell/Manifest
@@ -1,3 +1,4 @@
DIST codespell-2.2.4.tar.gz 241664 BLAKE2B 5f40003fdb840b926615b6eed74df90055b2ee47c534321289c3ed895c47cd2672909b152a53640899cc21960c1b3aa80c41eb344d9e23cea8fd13e998c71af6 SHA512 efbc62a3dd49781565f6d901aa9b08fc1106adf2c516365dd8d3684846e23b23bfda1e65c6530edf0de9462ccafd9d835bd541a8f0e1de14163c723ce041052d
DIST codespell-2.2.5.tar.gz 242918 BLAKE2B 18b4ff620edb54950ba2779ec610f15597d0aef5e4dded3ed2055ce7769e16d70dbac9cf990b2bdb6c216f8f6204e4a7790fe011ec53057553ca6981b4d8c851 SHA512 173eb13695ceccb4bb081907fc8d703e91922ec7adddc150aa2db1629353edff464c2318f2abaf78e8c96ab28f08e510897912f5bd48d69a6c50e025d470b53f
DIST codespell-2.2.6.tar.gz 300968 BLAKE2B f97aca1c1398cecd6257dc5fc8c0c6e8b35d34a82338e0ede4b03b6df8d030f095fbb8ae77a5bcfe6955f954a556fcea34927b4f44069010becd724b29a07184 SHA512 993734138e017324039a2954fc3559411aa7e3a96b8e6b6b2176985641225755adb9dde7125260211e531a1ecf1f1d82f2294434c21e8a35c7898212f3db3273
+DIST codespell-2.3.0.tar.gz 329791 BLAKE2B dd586645bd1d5ba956da85ab699eb205ebd3610e825ec9c7d85cac19dcb138f9e4561d95c79347e9509ba56d116844fbe9b2cb9380f724c9e5ec2bbdea7cd929 SHA512 2614ce6d47fadf62d1048efcd248a72486b1cab3332d10a143ef28bc441855330ad57ea0ce2c93546a93592d182053286255f35421e889518e6a66e31f8294b8
diff --git a/dev-util/codespell/codespell-2.3.0.ebuild b/dev-util/codespell/codespell-2.3.0.ebuild
new file mode 100644
index 000000000000..4c3a8ca7a665
--- /dev/null
+++ b/dev-util/codespell/codespell-2.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Check text files for common misspellings"
+HOMEPAGE="https://pypi.org/project/codespell
+ https://github.com/codespell-project/codespell"
+
+# Code licensed under GPL-2, dictionary licensed under CC-BY-SA-3.0
+LICENSE="GPL-2 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # Remove bundled dictionary
+ sed -e '/addopts/d' -i pyproject.toml || die
+}