summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-04-09 16:35:12 +0200
committerSebastian Pipping <sping@gentoo.org>2022-04-09 16:38:03 +0200
commit550c31473cb2bf5bb635a3660ecf9f52e2a741e1 (patch)
treec670544bd36c653e8868c532f03664349ceb3748 /dev-util/cram
parentdev-python/zope-configuration: Use pkgutil-style namespace for tests (diff)
downloadgentoo-550c31473cb2bf5bb635a3660ecf9f52e2a741e1.tar.gz
gentoo-550c31473cb2bf5bb635a3660ecf9f52e2a741e1.tar.bz2
gentoo-550c31473cb2bf5bb635a3660ecf9f52e2a741e1.zip
dev-util/cram: Add missing DISTUTILS_USE_SETUPTOOLS=no
Closes: https://bugs.gentoo.org/749888 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.30, Repoman-3.0.3
Diffstat (limited to 'dev-util/cram')
-rw-r--r--dev-util/cram/cram-0.7-r2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/cram/cram-0.7-r2.ebuild b/dev-util/cram/cram-0.7-r2.ebuild
new file mode 100644
index 000000000000..56867074f7fe
--- /dev/null
+++ b/dev-util/cram/cram-0.7-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Functional testing framework for command line applications"
+HOMEPAGE="https://bitheap.org/cram/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~x86"
+
+python_test() {
+ distutils_install_for_testing
+ "${EPYTHON}" "${TEST_DIR}"/scripts/cram tests || die "Tests fail with ${EPYTHON}"
+}